aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine/Makefile
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2009-02-22 22:34:56 +0800
committernobutaka <nobutaka@FreeBSD.org>2009-02-22 22:34:56 +0800
commite40f206055c27c481b50a35b97e8afdec05d3eb2 (patch)
treec0f12d42627639b368ab481ba2e3d2e1c8aaa8b0 /multimedia/libxine/Makefile
parentdf0b5d2abb2cd4bc86b7d46d535c25d5e0324412 (diff)
downloadfreebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.tar.gz
freebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.tar.zst
freebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.zip
- Update to 1.1.16.2.
- Add FAAD option for external libfaad support. [*] PR: ports/131955 [*] Submitted by: Jan Henrik Sylvester <me@janh.de>
Diffstat (limited to 'multimedia/libxine/Makefile')
-rw-r--r--multimedia/libxine/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 6b8f3d884f9a..06ce9064e8f3 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 1.1.15
-PORTREVISION= 5
+PORTVERSION= 1.1.16.2
CATEGORIES= multimedia ipv6
MASTER_SITES= SF
PKGNAMEPREFIX= lib
@@ -63,13 +62,14 @@ OPTIONS= ARTS "Enable aRts support" off \
AALIB "Enable aalib support" off \
IMAGEMAGICK "Enable ImageMagick support" off \
GTK2 "Enable gdkpixbuf support" off \
- WAVPACK "Enable WavPack support" on
+ WAVPACK "Enable WavPack support" on \
+ FAAD "Enable external faad support" off
MAN1= xine-config.1 xine-list-1.1.1
MAN5= xine.5
DOCSDIR= ${PREFIX}/share/doc/xine-lib
-PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.24"
+PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.25"
.include <bsd.port.pre.mk>
@@ -177,6 +177,13 @@ PLIST_SUB+= WITH_WAVPACK="@comment "
CONFIGURE_ARGS+= --without-wavpack
.endif
+.if defined(WITH_FAAD)
+LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
+CONFIGURE_ARGS+= --with-external-libfaad=yes
+.else
+CONFIGURE_ARGS+= --with-external-libfaad=no
+.endif
+
.if ${CONFIGURE_ARGS:M*--without-imagemagick*} == "" || ${CONFIGURE_ARGS:M*-disable-gdkpixbuf*} == ""
PLIST_SUB+= WITH_DMX_IMAGE=""
.else