aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-11-30 04:38:21 +0800
committeroliver <oliver@FreeBSD.org>2006-11-30 04:38:21 +0800
commit4688fcd4eb787fa05111b0289caeb03c0d79fe28 (patch)
tree7e2680b9b5ed4e3cda70343f499973954214914f /multimedia/libxine
parent4f3c9594b9524f8c40dde356671ad571eed23a25 (diff)
downloadfreebsd-ports-gnome-4688fcd4eb787fa05111b0289caeb03c0d79fe28.tar.gz
freebsd-ports-gnome-4688fcd4eb787fa05111b0289caeb03c0d79fe28.tar.zst
freebsd-ports-gnome-4688fcd4eb787fa05111b0289caeb03c0d79fe28.zip
make buildable on FreeBSD 4
PR: ports/103769 Approved by: maintainer timeout (62 days)
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile4
-rw-r--r--multimedia/libxine/files/patch-src:libffmpeg:libavcodec:h263.c18
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:xine_internal.h65
-rw-r--r--multimedia/libxine/files/patch-src_input_input_vcd.c18
-rw-r--r--multimedia/libxine/files/patch-src_libffmpeg_libavcodec_huffyuv.c10
-rw-r--r--multimedia/libxine/files/patch-src_libffmpeg_libavcodec_mpegvideo.c10
-rw-r--r--multimedia/libxine/files/patch-src_libffmpeg_libavcodec_vorbis.c11
7 files changed, 121 insertions, 15 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 92392737b8cf..cdbdd9f0db4d 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -33,6 +33,7 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
mad.2:${PORTSDIR}/audio/libmad
USE_BZIP2= yes
+USE_GCC= 3.4+
USE_GETTEXT= yes
USE_ICONV= yes
USE_X_PREFIX= yes
@@ -200,7 +201,8 @@ post-patch:
s|-L/usr/local/lib||g ; \
s|-I/usr/local/include||g ; \
s|-lgiconv|-liconv|g ; \
- s|-funroll-loops||g' ${WRKSRC}/configure
+ s|-funroll-loops||g ; \
+ s|LIBFFMPEG_CFLAGS|LIBFFMPEG_CPPFLAGS|g' ${WRKSRC}/configure
.if ${OSVERSION} >= 500035
@${REINPLACE_CMD} -e \
's|-malign-loops|-falign-loops|g ; \
diff --git a/multimedia/libxine/files/patch-src:libffmpeg:libavcodec:h263.c b/multimedia/libxine/files/patch-src:libffmpeg:libavcodec:h263.c
index 343662f7db50..b6577c5bae57 100644
--- a/multimedia/libxine/files/patch-src:libffmpeg:libavcodec:h263.c
+++ b/multimedia/libxine/files/patch-src:libffmpeg:libavcodec:h263.c
@@ -1,6 +1,14 @@
---- src/libffmpeg/libavcodec/h263.c.orig Sun Jul 9 23:38:11 2006
-+++ src/libffmpeg/libavcodec/h263.c Wed Aug 2 01:19:03 2006
-@@ -66,8 +66,8 @@
+--- src/libffmpeg/libavcodec/h263.c.orig Sun Jul 9 16:38:11 2006
++++ src/libffmpeg/libavcodec/h263.c Thu Sep 28 12:53:39 2006
+@@ -38,6 +38,7 @@
+ #include "mpegvideo.h"
+ #include "h263data.h"
+ #include "mpeg4data.h"
++#include "xine_internal.h"
+
+ //#undef NDEBUG
+ //#include <assert.h>
+@@ -66,8 +67,8 @@
static int h263p_decode_umotion(MpegEncContext * s, int pred);
static int h263_decode_block(MpegEncContext * s, DCTELEM * block,
int n, int coded);
@@ -11,7 +19,7 @@
int n, int coded, int intra, int rvlc);
static int mpeg4_get_block_length(MpegEncContext * s, DCTELEM * block, int n, int intra_dc,
uint8_t *scan_table);
-@@ -4684,7 +4684,7 @@
+@@ -4684,7 +4685,7 @@
* @param dir_ptr the prediction direction will be stored here
* @return the quantized dc
*/
@@ -20,7 +28,7 @@
{
int level, code;
-@@ -4729,7 +4729,7 @@
+@@ -4729,7 +4730,7 @@
* decodes a block.
* @return <0 if an error occured
*/
diff --git a/multimedia/libxine/files/patch-src:xine-engine:xine_internal.h b/multimedia/libxine/files/patch-src:xine-engine:xine_internal.h
index 88f8ce9033a7..c53bb6712627 100644
--- a/multimedia/libxine/files/patch-src:xine-engine:xine_internal.h
+++ b/multimedia/libxine/files/patch-src:xine-engine:xine_internal.h
@@ -1,7 +1,7 @@
---- src/xine-engine/xine_internal.h.orig Tue Apr 26 17:09:12 2005
-+++ src/xine-engine/xine_internal.h Sat Apr 30 14:16:33 2005
-@@ -70,6 +70,77 @@
- # include <xine/info_helper.h>
+--- src/xine-engine/xine_internal.h.orig Sat Apr 22 00:46:33 2006
++++ src/xine-engine/xine_internal.h Thu Sep 28 16:13:27 2006
+@@ -72,6 +72,124 @@
+ # include <xine/alphablend.h>
#endif
+#ifndef INT8_MIN
@@ -28,11 +28,41 @@
+#define INT32_MIN (-0x7fffffff-1)
+#endif
+
++#ifndef PRIdMAX
++#define PRIdMAX "lld"
++#endif
++
++#ifndef SCNdMAX
++#define SCNdMAX "lld"
++#endif
++
+#ifndef PRIiMAX
-+#define PRIiMAX "lld"
++#define PRIiMAX "lld"
+typedef long long intmax_t;
+#endif
+
++
++#ifndef PRId32
++#define PRId32 "d"
++#endif
++
++#ifndef SCNd32
++#define SCNd32 "d"
++#endif
++
++#ifndef PRIdFAST16
++#define PRIdFAST16 "d"
++#endif
++
++#ifndef PRIdFAST32
++#define PRIdFAST32 "d"
++#endif
++
++#ifndef SCNu32
++#define SCNu32 "u"
++#endif
++
++
+#ifndef PRId64
+#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
+#define PRId64 "ld"
@@ -41,14 +71,31 @@
+#endif
+#endif
+
-+#ifndef PRIdMAX
-+#define PRIdMAX "lld"
++#ifndef SCNd64
++#define SCNd64 PRId64
++#endif
++
++#ifndef PRIu64
++#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
++#define PRIu64 "lu"
++#else if defined(__i386__) || defined(__powerpc__)
++#define PRIu64 "llu"
++#endif
+#endif
+
-+#ifndef SCNdMAX
-+#define SCNdMAX "lld"
++#ifndef SCNu64
++#define SCNu64 PRIu64
+#endif
+
++#ifndef PRIX64
++#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
++#define PRIX64 "lX"
++#else if defined(__i386__) || defined(__powerpc__)
++#define PRIX64 "llX"
++#endif
++#endif
++
++
+#ifndef PRIx32
+#define PRIx32 "x"
+#endif
diff --git a/multimedia/libxine/files/patch-src_input_input_vcd.c b/multimedia/libxine/files/patch-src_input_input_vcd.c
new file mode 100644
index 000000000000..aea48f003666
--- /dev/null
+++ b/multimedia/libxine/files/patch-src_input_input_vcd.c
@@ -0,0 +1,18 @@
+--- src/input/input_vcd.c.orig Thu Sep 28 06:51:16 2006
++++ src/input/input_vcd.c Thu Sep 28 07:03:55 2006
+@@ -25,7 +25,6 @@
+ #include "config.h"
+ #endif
+
+-#include <netinet/in.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
+@@ -34,6 +33,7 @@
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+ #include <string.h>
++#include <netinet/in.h>
+ #ifdef HAVE_LINUX_CDROM_H
+ # include <linux/cdrom.h>
+ #endif
diff --git a/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_huffyuv.c b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_huffyuv.c
new file mode 100644
index 000000000000..2a8cc071402b
--- /dev/null
+++ b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_huffyuv.c
@@ -0,0 +1,10 @@
+--- src/libffmpeg/libavcodec/huffyuv.c.orig Thu Sep 28 13:25:07 2006
++++ src/libffmpeg/libavcodec/huffyuv.c Thu Sep 28 13:25:32 2006
+@@ -30,6 +30,7 @@
+ #include "bitstream.h"
+ #include "avcodec.h"
+ #include "dsputil.h"
++#include "xine_internal.h"
+
+ #define VLC_BITS 11
+
diff --git a/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_mpegvideo.c b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_mpegvideo.c
new file mode 100644
index 000000000000..54019b871565
--- /dev/null
+++ b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_mpegvideo.c
@@ -0,0 +1,10 @@
+--- src/libffmpeg/libavcodec/mpegvideo.c.orig Thu Sep 28 13:27:10 2006
++++ src/libffmpeg/libavcodec/mpegvideo.c Thu Sep 28 13:27:35 2006
+@@ -30,6 +30,7 @@
+ #include "mpegvideo.h"
+ #include "faandct.h"
+ #include <limits.h>
++#include "xine_internal.h"
+
+ #ifdef USE_FASTMEMCPY
+ #include "fastmemcpy.h"
diff --git a/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_vorbis.c b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_vorbis.c
new file mode 100644
index 000000000000..159f6b4154b3
--- /dev/null
+++ b/multimedia/libxine/files/patch-src_libffmpeg_libavcodec_vorbis.c
@@ -0,0 +1,11 @@
+--- src/libffmpeg/libavcodec/vorbis.c.orig Thu Sep 28 13:27:16 2006
++++ src/libffmpeg/libavcodec/vorbis.c Thu Sep 28 13:27:41 2006
+@@ -29,6 +29,8 @@
+ #include "dsputil.h"
+
+ #include "vorbis.h"
++#include "xine_internal.h"
++
+
+ #define V_NB_BITS 8
+ #define V_NB_BITS2 11