aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-05-25 19:25:19 +0800
committerpav <pav@FreeBSD.org>2007-05-25 19:25:19 +0800
commit8a8c185c89d9734929798f509b712dd127c13fd8 (patch)
treee4ee59b0cb2e93fcb0e5e764c84c8c736061fd38 /multimedia/libxine
parent1d3e51bbbbd02217578db63f29facc22cba4d055 (diff)
downloadfreebsd-ports-gnome-8a8c185c89d9734929798f509b712dd127c13fd8.tar.gz
freebsd-ports-gnome-8a8c185c89d9734929798f509b712dd127c13fd8.tar.zst
freebsd-ports-gnome-8a8c185c89d9734929798f509b712dd127c13fd8.zip
- Fix build of XvMC plugin with new X.org, unmark BROKEN
- While here, fix DTS decoder runtime
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 7070d42dba38..c7fc43cc0a4c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.1.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -32,8 +32,6 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
mad.2:${PORTSDIR}/audio/libmad \
dca.0:${PORTSDIR}/multimedia/libdca
-BROKEN= Incorrect pkg-plist
-
USE_GCC= 3.4+
USE_GETTEXT= yes
USE_ICONV= yes
@@ -115,7 +113,7 @@ CONFIGURE_ARGS+= --disable-pulseaudio
CONFIGURE_ARGS+=--with-xvmc-lib=XvMCNVIDIA
LIB_DEPENDS+= XvMCNVIDIA.1:${PORTSDIR}/x11/nvidia-driver
.else
-CONFIGURE_ARGS+=--with-xvmc-lib=XvMC
+CONFIGURE_ARGS+=--with-xvmc-lib=XvMCW
LIB_DEPENDS+= XvMC.1:${PORTSDIR}/x11/libXvMC
.endif
PLIST_SUB+= WITH_XVMC=""
@@ -239,4 +237,7 @@ pre-configure:
s|-malign-functions|-falign-functions|g' ${WRKSRC}/configure
.endif
+pre-build:
+ @${CP} -p ${LOCALBASE}/include/dts.h ${WRKSRC}/src/libdts/
+
.include <bsd.port.post.mk>