aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2009-02-22 22:34:56 +0800
committernobutaka <nobutaka@FreeBSD.org>2009-02-22 22:34:56 +0800
commite40f206055c27c481b50a35b97e8afdec05d3eb2 (patch)
treec0f12d42627639b368ab481ba2e3d2e1c8aaa8b0 /multimedia/libxine
parentdf0b5d2abb2cd4bc86b7d46d535c25d5e0324412 (diff)
downloadfreebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.tar.gz
freebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.tar.zst
freebsd-ports-gnome-e40f206055c27c481b50a35b97e8afdec05d3eb2.zip
- Update to 1.1.16.2.
- Add FAAD option for external libfaad support. [*] PR: ports/131955 [*] Submitted by: Jan Henrik Sylvester <me@janh.de>
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile15
-rw-r--r--multimedia/libxine/distinfo6
-rw-r--r--multimedia/libxine/files/patch-configure58
-rw-r--r--multimedia/libxine/files/patch-misc_Makefile.in10
-rw-r--r--multimedia/libxine/files/patch-src__xine-engine__buffer.h11
-rw-r--r--multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in13
-rw-r--r--multimedia/libxine/pkg-plist2
7 files changed, 85 insertions, 30 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 6b8f3d884f9a..06ce9064e8f3 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 1.1.15
-PORTREVISION= 5
+PORTVERSION= 1.1.16.2
CATEGORIES= multimedia ipv6
MASTER_SITES= SF
PKGNAMEPREFIX= lib
@@ -63,13 +62,14 @@ OPTIONS= ARTS "Enable aRts support" off \
AALIB "Enable aalib support" off \
IMAGEMAGICK "Enable ImageMagick support" off \
GTK2 "Enable gdkpixbuf support" off \
- WAVPACK "Enable WavPack support" on
+ WAVPACK "Enable WavPack support" on \
+ FAAD "Enable external faad support" off
MAN1= xine-config.1 xine-list-1.1.1
MAN5= xine.5
DOCSDIR= ${PREFIX}/share/doc/xine-lib
-PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.24"
+PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.25"
.include <bsd.port.pre.mk>
@@ -177,6 +177,13 @@ PLIST_SUB+= WITH_WAVPACK="@comment "
CONFIGURE_ARGS+= --without-wavpack
.endif
+.if defined(WITH_FAAD)
+LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
+CONFIGURE_ARGS+= --with-external-libfaad=yes
+.else
+CONFIGURE_ARGS+= --with-external-libfaad=no
+.endif
+
.if ${CONFIGURE_ARGS:M*--without-imagemagick*} == "" || ${CONFIGURE_ARGS:M*-disable-gdkpixbuf*} == ""
PLIST_SUB+= WITH_DMX_IMAGE=""
.else
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index b5f2fc0c003a..72e556bf2cd8 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1,3 +1,3 @@
-MD5 (xine-lib-1.1.15.tar.bz2) = 42a2b4893b7f892eb334de2fc36d49c8
-SHA256 (xine-lib-1.1.15.tar.bz2) = 07ddf2a9f521417dd2f097534a52ddd9d2883679932f965ae7e7b0125d3c9dcc
-SIZE (xine-lib-1.1.15.tar.bz2) = 7478750
+MD5 (xine-lib-1.1.16.2.tar.bz2) = 336dd1f6266e9f943430ca6009b7aa7e
+SHA256 (xine-lib-1.1.16.2.tar.bz2) = 67f2469faee964b75f43459547b5e2f9a407b8dc30cbeffa989cce312e16b2c1
+SIZE (xine-lib-1.1.16.2.tar.bz2) = 7407399
diff --git a/multimedia/libxine/files/patch-configure b/multimedia/libxine/files/patch-configure
index 7349b2d8a8fe..de875dfd1d26 100644
--- a/multimedia/libxine/files/patch-configure
+++ b/multimedia/libxine/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-06-28 22:13:45.000000000 -0500
-+++ configure 2008-06-28 22:13:45.000000000 -0500
-@@ -10049,6 +10049,12 @@
+--- configure.orig 2009-02-11 03:35:05.000000000 +0900
++++ configure 2009-02-22 18:37:34.000000000 +0900
+@@ -10363,6 +10363,12 @@
fi
;;
@@ -11,9 +11,9 @@
+ ;;
+
netbsd* | netbsdelf*-gnu)
- if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
+ if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
-@@ -22431,7 +22437,7 @@
+@@ -13853,7 +13859,7 @@
if test -z "$haveit"; then
LIBICONV="${LIBICONV}${LIBICONV:+ }-L$found_dir"
fi
@@ -22,7 +22,51 @@
LIBICONV="${LIBICONV}${LIBICONV:+ }$found_so"
else
LIBICONV="${LIBICONV}${LIBICONV:+ }-l$name"
-@@ -37670,6 +37676,8 @@
+@@ -26519,12 +26525,12 @@
+ pkg_cv_CACA_CFLAGS="$CACA_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
++ pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -26537,12 +26543,12 @@
+ pkg_cv_CACA_LIBS="$CACA_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
++ pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -26561,9 +26567,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- CACA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 "`
++ CACA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 "`
+ else
+- CACA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 "`
++ CACA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 "`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$CACA_PKG_ERRORS" >&5
+@@ -29191,6 +29197,8 @@
fi
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
@@ -31,7 +75,7 @@
fi
if test "x$no_libFLAC" = "x" ; then
-@@ -50370,7 +50378,7 @@
+@@ -42228,7 +42236,7 @@
xinelibdir='${libdir}/xine'
xinedatadir='${datadir}/xine'
diff --git a/multimedia/libxine/files/patch-misc_Makefile.in b/multimedia/libxine/files/patch-misc_Makefile.in
index def60e95b7cf..3e944eb6a577 100644
--- a/multimedia/libxine/files/patch-misc_Makefile.in
+++ b/multimedia/libxine/files/patch-misc_Makefile.in
@@ -1,11 +1,11 @@
---- misc/Makefile.in.orig 2008-04-21 22:50:31.000000000 +0900
-+++ misc/Makefile.in 2008-04-22 00:22:48.000000000 +0900
-@@ -207,7 +207,7 @@
- JACK_CFLAGS = @JACK_CFLAGS@
+--- misc/Makefile.in.orig 2009-02-11 03:34:49.000000000 +0900
++++ misc/Makefile.in 2009-02-22 09:05:26.000000000 +0900
+@@ -212,7 +212,7 @@
JACK_LIBS = @JACK_LIBS@
KSTAT_LIBS = @KSTAT_LIBS@
+ LD = @LD@
-LDFLAGS = @LDFLAGS@
+LDFLAGS = @LDFLAGS@ @PTHREAD_LIBS@
+ LDFLAGS_NOUNDEFINED = @LDFLAGS_NOUNDEFINED@
LIBCDIO_CFLAGS = @LIBCDIO_CFLAGS@
LIBCDIO_LIBS = @LIBCDIO_LIBS@
- LIBDTS_CFLAGS = @LIBDTS_CFLAGS@
diff --git a/multimedia/libxine/files/patch-src__xine-engine__buffer.h b/multimedia/libxine/files/patch-src__xine-engine__buffer.h
deleted file mode 100644
index 3a416dbcc650..000000000000
--- a/multimedia/libxine/files/patch-src__xine-engine__buffer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xine-engine/buffer.h.orig 2008-07-16 17:01:56.000000000 -0400
-+++ src/xine-engine/buffer.h 2008-10-23 14:25:45.000000000 -0400
-@@ -676,7 +676,7 @@
- /* convert xine_waveformatex struct from little endian */
- void _x_waveformatex_le2me( xine_waveformatex *wavex ) XINE_PROTECTED;
-
--static inline _x_is_fourcc(void *ptr, void *tag) {
-+static inline int _x_is_fourcc(void *ptr, void *tag) {
- return memcmp(ptr, tag, 4) == 0;
- }
-
diff --git a/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in b/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in
new file mode 100644
index 000000000000..144b57e0c39f
--- /dev/null
+++ b/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in
@@ -0,0 +1,13 @@
+--- src/combined/ffmpeg/Makefile.in.orig 2009-02-22 09:21:57.000000000 +0900
++++ src/combined/ffmpeg/Makefile.in 2009-02-22 09:51:00.000000000 +0900
+@@ -889,8 +889,8 @@
+
+ avcodec_audio.list avcodec_video.list:
+ echo '#include "$(srcdir)/ffmpeg_decoder.h"' | $(AV_CPP) - |\
+- sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' |\
+- head -n -1 >$@
++ sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' >$@
++ sed -i.bak -e '$$d' $@
+
+ # Generate the mappings. These are #included where needed.
+ ff_%_list.h: $(srcdir)/mkcodeclist.pl avcodec_%.list $(srcdir)/xine_%.list
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index 7bc9061550b5..978db7a537b2 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -33,6 +33,7 @@ include/xine/video_overlay.h
include/xine/vo_scale.h
include/xine/xine_buffer.h
include/xine/xine_internal.h
+include/xine/xine_mmx.h
include/xine/xine_plugin.h
include/xine/xineintl.h
include/xine/xineutils.h
@@ -179,6 +180,7 @@ share/aclocal/xine.m4
%%DOCSDIR%%/hackersguide/post_frame.png
share/locale/cs/LC_MESSAGES/libxine1.mo
share/locale/de/LC_MESSAGES/libxine1.mo
+share/locale/en_US/LC_MESSAGES/libxine1.mo
share/locale/eo/LC_MESSAGES/libxine1.mo
share/locale/es/LC_MESSAGES/libxine1.mo
share/locale/eu/LC_MESSAGES/libxine1.mo