aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxine
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-06-23 06:49:45 +0800
committernox <nox@FreeBSD.org>2011-06-23 06:49:45 +0800
commit0e2f6d35a69dd46073f0e1722047af2efac3c807 (patch)
tree5b4a7a99088cc9f558aa7c5d88bbaf87c8f97f0c /multimedia/libxine
parent1970247ce7f578ac211890153fe7e1e435bf3a1f (diff)
downloadfreebsd-ports-gnome-0e2f6d35a69dd46073f0e1722047af2efac3c807.tar.gz
freebsd-ports-gnome-0e2f6d35a69dd46073f0e1722047af2efac3c807.tar.zst
freebsd-ports-gnome-0e2f6d35a69dd46073f0e1722047af2efac3c807.zip
Fix build with clang.
Submitted by: Andrius Morkunas, dim
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile4
-rw-r--r--multimedia/libxine/files/patch-src:xine-engine:post.h11
2 files changed, 14 insertions, 1 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 24183f1046e9..30f9235ce462 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.1.19
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib/${PORTVERSION}
PKGNAMEPREFIX= lib
@@ -256,6 +256,8 @@ post-patch:
${WRKSRC}/misc/cdda_server.c
@${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
${WRKSRC}/src/input/libdvdnav/dvd_input.c
+ @${REINPLACE_CMD} -e "s|#define _ATOM QT_ATOM('', '', '', '')||" \
+ ${WRKSRC}/src/demuxers/demux_qt.c
pre-configure:
@${REINPLACE_CMD} -e \
diff --git a/multimedia/libxine/files/patch-src:xine-engine:post.h b/multimedia/libxine/files/patch-src:xine-engine:post.h
new file mode 100644
index 000000000000..ca430dcdffcc
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:xine-engine:post.h
@@ -0,0 +1,11 @@
+--- src/xine-engine/post.h.orig 2010-06-03 15:54:12.000000000 +0200
++++ src/xine-engine/post.h 2010-06-03 15:59:20.000000000 +0200
+@@ -377,7 +377,7 @@ static xine_post_api_parameter_t temp_p[
+
+ #define PARAM_ITEM( param_type, var, enumv, min, max, readonly, descr ) \
+ { param_type, #var, sizeof(temp_s.var), \
+- (char*)&temp_s.var-(char*)&temp_s, enumv, min, max, readonly, descr },
++ offsetof(typeof(temp_s), var), enumv, min, max, readonly, descr },
+
+ #define END_PARAM_DESCR( name ) \
+ { POST_PARAM_TYPE_LAST, NULL, 0, 0, NULL, 0, 0, 1, NULL } \