aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libxspf
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2009-03-07 19:33:09 +0800
committered <ed@FreeBSD.org>2009-03-07 19:33:09 +0800
commitbce801ae5e8d690cec1f644e4e39749492cbedae (patch)
treea9eeb534fadc50b1fd92f79946e3b378ef3c0060 /multimedia/libxspf
parentf6170cb7ba9fc78de29698775dba2ae016945862 (diff)
downloadfreebsd-ports-gnome-bce801ae5e8d690cec1f644e4e39749492cbedae.tar.gz
freebsd-ports-gnome-bce801ae5e8d690cec1f644e4e39749492cbedae.tar.zst
freebsd-ports-gnome-bce801ae5e8d690cec1f644e4e39749492cbedae.zip
Add libxspf, which is basically the new version of libspiff.
Because this new version is incompatible with libxspf (big API rename), keep libspiff in the tree. Applications still need some time to migrate to libxspf. This port is heavily based on the libspiff port. The only change is the addition of pkg-config support.
Diffstat (limited to 'multimedia/libxspf')
-rw-r--r--multimedia/libxspf/Makefile35
-rw-r--r--multimedia/libxspf/distinfo3
-rw-r--r--multimedia/libxspf/pkg-descr5
-rw-r--r--multimedia/libxspf/pkg-plist33
4 files changed, 76 insertions, 0 deletions
diff --git a/multimedia/libxspf/Makefile b/multimedia/libxspf/Makefile
new file mode 100644
index 000000000000..5e06fe61f6ae
--- /dev/null
+++ b/multimedia/libxspf/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libxspf
+# Date Created: 7 March 2009
+# Whom: Ed Schouten <ed@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxspf
+PORTVERSION= 1.2.0
+CATEGORIES= multimedia
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=libspiff
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= An XSPF parsing library
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+# We need 0.7.5, which uses pkg-config
+BUILD_DEPENDS= uriparser>=0.7.5:${PORTSDIR}/net/uriparser
+RUN_DEPENDS= uriparser>=0.7.5:${PORTSDIR}/net/uriparser
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-expat=${LOCALBASE} --disable-test
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's|$$(libdir)/pkgconfig|$$(libdir)data/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/multimedia/libxspf/distinfo b/multimedia/libxspf/distinfo
new file mode 100644
index 000000000000..c12c20a50df5
--- /dev/null
+++ b/multimedia/libxspf/distinfo
@@ -0,0 +1,3 @@
+MD5 (libxspf-1.2.0.tar.bz2) = eceb3bf8fd4af3b09ea06c5c029cd647
+SHA256 (libxspf-1.2.0.tar.bz2) = ba9e93a0066469b074b4022b480004651ad3aa5b4313187fd407d833f79b43a5
+SIZE (libxspf-1.2.0.tar.bz2) = 372483
diff --git a/multimedia/libxspf/pkg-descr b/multimedia/libxspf/pkg-descr
new file mode 100644
index 000000000000..52e14d25aa69
--- /dev/null
+++ b/multimedia/libxspf/pkg-descr
@@ -0,0 +1,5 @@
+libxspf is a parser library for the XML Shareable Playlist Format
+(XSPF). XSPF is an open format for playlists. The XSPF specification has
+been written by Xiph.
+
+WWW: http://libspiff.sourceforge.net/
diff --git a/multimedia/libxspf/pkg-plist b/multimedia/libxspf/pkg-plist
new file mode 100644
index 000000000000..7edfc31aa751
--- /dev/null
+++ b/multimedia/libxspf/pkg-plist
@@ -0,0 +1,33 @@
+bin/xspf_check
+bin/xspf_strip
+include/xspf/ProjectOpus/ProjectOpusPlaylistExtension.h
+include/xspf/ProjectOpus/ProjectOpusPlaylistExtensionReader.h
+include/xspf/ProjectOpus/ProjectOpusPlaylistExtensionWriter.h
+include/xspf/Xspf.h
+include/xspf/XspfChunkCallback.h
+include/xspf/XspfData.h
+include/xspf/XspfDateTime.h
+include/xspf/XspfDefines.h
+include/xspf/XspfExtension.h
+include/xspf/XspfExtensionReader.h
+include/xspf/XspfExtensionReaderFactory.h
+include/xspf/XspfExtensionWriter.h
+include/xspf/XspfIndentFormatter.h
+include/xspf/XspfProps.h
+include/xspf/XspfReader.h
+include/xspf/XspfReaderCallback.h
+include/xspf/XspfSeamlessFormatter.h
+include/xspf/XspfStack.h
+include/xspf/XspfToolbox.h
+include/xspf/XspfTrack.h
+include/xspf/XspfVersion.h
+include/xspf/XspfWriter.h
+include/xspf/XspfXmlFormatter.h
+include/xspf/xspf_c.h
+lib/libxspf.a
+lib/libxspf.la
+lib/libxspf.so
+lib/libxspf.so.4
+libdata/pkgconfig/xspf.pc
+@dirrm include/xspf/ProjectOpus
+@dirrm include/xspf