aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/linux-divxplayer/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-05-20 12:26:21 +0800
committerlioux <lioux@FreeBSD.org>2002-05-20 12:26:21 +0800
commit48ca83c32da847fc6de4120ee06a550170169ed3 (patch)
tree74a23411b07219cce896b85cfe437dfb46b3f6b3 /multimedia/linux-divxplayer/Makefile
parentedf3475bafdb84ac75321224e626efc775ce9e64 (diff)
downloadfreebsd-ports-gnome-48ca83c32da847fc6de4120ee06a550170169ed3.tar.gz
freebsd-ports-gnome-48ca83c32da847fc6de4120ee06a550170169ed3.tar.zst
freebsd-ports-gnome-48ca83c32da847fc6de4120ee06a550170169ed3.zip
o New port divxplayer version 2.0 alpha: DivX(TM) Video Player for
Linux from DivX.com o It is still alpha material so probably does not work for most. PKGMESSAGE warns about that
Diffstat (limited to 'multimedia/linux-divxplayer/Makefile')
-rw-r--r--multimedia/linux-divxplayer/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/multimedia/linux-divxplayer/Makefile b/multimedia/linux-divxplayer/Makefile
new file mode 100644
index 000000000000..617783a28643
--- /dev/null
+++ b/multimedia/linux-divxplayer/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: divx.com player
+# Date created: Sun May 19 22:17:41 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= divxplayer
+PORTVERSION= 0.2.0
+CATEGORIES= graphics linux
+MASTER_SITES= http://download.divx.com/player/
+PKGNAMEPREFIX= linux-
+DISTNAME= divx-player-installer
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= \
+ ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base-7
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+STRIP=
+
+WRKSRC= ${WRKDIR}/divx-player-installer
+
+STRIP_CMD= ${LINUXBASE}/usr/bin/strip
+
+.if exists(/usr/bin/brandelf)
+BRANDELF?= /usr/bin/brandelf
+.else
+BRANDELF?= brandelf
+.endif
+
+BINARY_NAME= divxPlayer.bin
+
+post-patch:
+ @${SED} -e "s|%%DATADIR%%|${DATADIR}|" ${FILESDIR}/wrapper.sh \
+ > ${WRKDIR}/wrapper.sh
+
+pre-install:
+.if exists(${STRIP_CMD})
+ @${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
+.endif
+ @${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
+
+do-install:
+# skin files
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/Skins
+ @${INSTALL_DATA} ${WRKSRC}/Skins/* ${DATADIR}/Skins
+# player
+ @${INSTALL_PROGRAM} ${WRKSRC}/${BINARY_NAME} ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh \
+ ${PREFIX}/bin/${BINARY_NAME:S/.bin$//}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>