aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/lives/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-01-26 23:56:13 +0800
committersat <sat@FreeBSD.org>2007-01-26 23:56:13 +0800
commit47059dbdfc8721e5a1f2a8f402300d9eb1c144a7 (patch)
treedf5cb2831ae8daf5cb277f0609ec13f14bb514fc /multimedia/lives/Makefile
parent5f9db5390dca4caa196fd441af44374ae78874c7 (diff)
downloadfreebsd-ports-gnome-47059dbdfc8721e5a1f2a8f402300d9eb1c144a7.tar.gz
freebsd-ports-gnome-47059dbdfc8721e5a1f2a8f402300d9eb1c144a7.tar.zst
freebsd-ports-gnome-47059dbdfc8721e5a1f2a8f402300d9eb1c144a7.zip
Add port multimedia/lives:
LiVES is a Free, Open Source video editor *and* a VJ tool. LiVES lets you start editing and making video right away, without having to worry about formats, frame sizes, or framerates. LiVES will let you start creating your own tools, utilities and effects via the built in RFX builder. LiVES is aimed at the digital video artist who wants to create their own content, the video editor who wants to produce professional looking video, and the VJ who wants to captivate with spectacular images. WWW: http://lives.sourceforge.net/
Diffstat (limited to 'multimedia/lives/Makefile')
-rw-r--r--multimedia/lives/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
new file mode 100644
index 000000000000..3ba3d76b41d7
--- /dev/null
+++ b/multimedia/lives/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: lives
+# Date created: 3 November 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lives
+DISTVERSION= 0.9.8.2
+CATEGORIES= multimedia
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Video editing system
+
+LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ jack.0:${PORTSDIR}/audio/jack \
+ visual-0.4.0:${PORTSDIR}/graphics/libvisual04 \
+ theora.2:${PORTSDIR}/multimedia/libtheora \
+ avcodec.1:${PORTSDIR}/multimedia/ffmpeg-devel \
+ dv.4:${PORTSDIR}/multimedia/libdv \
+ matroska.0:${PORTSDIR}/multimedia/libmatroska \
+ x264.50:${PORTSDIR}/multimedia/x264
+BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ sox:${PORTSDIR}/audio/sox \
+ transcode:${PORTSDIR}/multimedia/transcode \
+ mjpegtools>=1.8.0:${PORTSDIR}/multimedia/mjpegtools \
+ xmms:${PORTSDIR}/multimedia/xmms \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ ogg123:${PORTSDIR}/audio/vorbis-tools \
+ cdda2wav:${PORTSDIR}/sysutils/cdrtools \
+ gs:${PORTSDIR}/print/ghostscript-gnu \
+ sswf:${PORTSDIR}/graphics/sswf \
+ ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PERL5= yes
+USE_GNOME= gtk20
+USE_GETTEXT= yes
+USE_SDL= yes
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -g -fPIC
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+LC_MESSAGES_NAMES= lives
+
+post-patch:
+ @${REINPLACE_CMD} -e '/test.*==/s|==|=|g' -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/LDFLAGS/s|-ldld||;s|-ldl||'\
+ ${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
+ @${REINPLACE_CMD} -e 's|-d alsa|-d oss|' ${WRKSRC}/src/main.c
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|weed-plugins||' ${WRKSRC}/lives-plugins/Makefile.in
+ @${REINPLACE_CMD} -e '/^docdir/s|=.*|=${DOCSDIR}|' ${WRKSRC}/Makefile.in
+ @${FIND} ${WRKSRC}/ -name Makefile.in |\
+ ${XARGS} ${EGREP} -lm1 '(-O3|-fexpensive-optimizations)' |\
+ ${XARGS} ${REINPLACE_CMD} -e 's|-O3||;s|-fexpensive-optimizations||'
+
+.include <bsd.port.mk>