aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/lives/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-24 02:52:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-24 02:52:19 +0800
commit500d59d447cee2f9ab49cd0ce0a003e4b832f2d3 (patch)
tree5bf936247fb6153ced0e6fee58ffdc72c2640548 /multimedia/lives/Makefile
parent0fae4a4b5f15c3d570fe197b80a2f742c15197c5 (diff)
downloadfreebsd-ports-gnome-500d59d447cee2f9ab49cd0ce0a003e4b832f2d3.tar.gz
freebsd-ports-gnome-500d59d447cee2f9ab49cd0ce0a003e4b832f2d3.tar.zst
freebsd-ports-gnome-500d59d447cee2f9ab49cd0ce0a003e4b832f2d3.zip
- Switch to options helpers
- Fix shebangs Approved by: portmgr blanket
Diffstat (limited to 'multimedia/lives/Makefile')
-rw-r--r--multimedia/lives/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index a7dc2bbb0690..c138f2a3cc30 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -3,8 +3,9 @@
PORTNAME= lives
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Video editing system
@@ -44,7 +45,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME:tl}
USES= ghostscript:run libtool pathfix perl5 pkgconfig python \
shebangfix tar:bzip2
SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
- smogrify tools/autolives.pl
+ smogrify tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
+ lives-plugins/plugins/playback/audiostream/audiostreamer.pl
GNU_CONFIGURE= yes
USE_CSTD= gnu89
USE_GNOME= gtk30 intltool
@@ -71,17 +73,14 @@ DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
DOXYGEN_CONFIGURE_OFF= --disable-doxygen
FREI0R_BUILD_DEPENDS= frei0r>0:${PORTSDIR}/graphics/frei0r
FREI0R_RUN_DEPENDS= frei0r>0:${PORTSDIR}/graphics/frei0r
+FREI0R_CONFIGURE_ENV_OFF= ac_cv_header_frei0r_h=no
MATROSKA_RUN_DEPENDS= mkvmerge:${PORTSDIR}/multimedia/mkvtoolnix
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MFREI0R}
-CONFIGURE_ENV+= ac_cv_header_frei0r_h=no
-.endif
-
post-patch:
+ @${REINPLACE_CMD} -e 's|${perl_OLD_CMD}|${perl_CMD}|' \
+ ${WRKSRC}/build-lives-rfx-plugin
@${REINPLACE_CMD} -e 's| install-docDATA||g; s|-$$(VERSION)||g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|: install-data-local |: |g; s|-ldl||' \
@@ -95,17 +94,15 @@ post-patch:
@${REINPLACE_CMD} '/selectRandom/d' \
${WRKSRC}/lives-plugins/weed-plugins/projectM.cpp
-pre-build:
-.if ${PORT_OPTIONS:MNLS}
+pre-build-NLS-on:
@cd ${WRKSRC}/po && ${DO_MAKE_BUILD} update-po
-.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.if ${PORT_OPTIONS:MDOXYGEN}
+
+post-install-DOXYGEN-on:
@(cd ${STAGEDIR}${PREFIX} && ${FIND} ${DOCSDIR:S|${PREFIX}/||}/html \
! -type d >> ${TMPPLIST})
-.endif
.include <bsd.port.mk>