aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/lives/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2008-04-09 23:51:53 +0800
committersat <sat@FreeBSD.org>2008-04-09 23:51:53 +0800
commitd7f2962d27039df3f7498620264c232801509fe1 (patch)
treee5b87e31c010dad60c3b703a655ce1ab9f19bf41 /multimedia/lives/Makefile
parent41e89829f433b1b8d6e14d80f69de8381083b9db (diff)
downloadfreebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.tar.gz
freebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.tar.zst
freebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.zip
- Update to 0.9.8.10
Diffstat (limited to 'multimedia/lives/Makefile')
-rw-r--r--multimedia/lives/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 926ce3855ab4..5d96a977fbbb 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lives
-DISTVERSION= 0.9.8.6
-PORTREVISION= 3
+DISTVERSION= 0.9.8.10
CATEGORIES= multimedia
MASTER_SITES= http://www.xs4all.nl/%7Esalsaman/lives/current/ CENKES
DISTNAME= LiVES-${DISTVERSION}
@@ -29,6 +28,7 @@ LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick \
x264.50:${PORTSDIR}/multimedia/x264
BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ mencoder:${PORTSDIR}/multimedia/mencoder \
sox:${PORTSDIR}/audio/sox \
transcode:${PORTSDIR}/multimedia/transcode \
xmms:${PORTSDIR}/multimedia/xmms \
@@ -46,23 +46,25 @@ USE_GNOME= gtk20
USE_GETTEXT= yes
USE_GHOSTSCRIPT_RUN= yes
USE_SDL= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -g -fPIC
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -fPIC
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
LC_MESSAGES_NAMES= lives
+PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
post-patch:
@${REINPLACE_CMD} -e 's|i<FX_KEYS_MAX_VIRTUAL|i<prefs->rte_keys_virtual|' ${WRKSRC}/src/rte_window.c
- @${REINPLACE_CMD} -e '/test.*==/s|==|=|g' -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/LDFLAGS/s|-ldld||;s|-ldl||'\
+ @${REINPLACE_CMD} -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/LDFLAGS/s|-ldl||'\
${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
@${REINPLACE_CMD} -e 's|-d alsa|-d oss|' ${WRKSRC}/src/main.c
@${REINPLACE_CMD} -e '/^SUBDIRS/s|weed-plugins||' ${WRKSRC}/lives-plugins/Makefile.in
- @${REINPLACE_CMD} -e '/^docdir/s|=.*|=${DOCSDIR}|' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^docdir/s|=.*|=${DOCSDIR}|;\
+ /update_with_plugins.*install/d' ${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC}/ -name Makefile.in |\
${XARGS} ${EGREP} -lm1 '(-O3|-fexpensive-optimizations)' |\
${XARGS} ${REINPLACE_CMD} -e 's|-O3||;s|-fexpensive-optimizations||'
+ @${REINPLACE_CMD} -e 's|\*\.py|*_encoder.py|' ${WRKSRC}/lives-plugins/marcos-encoders/Makefile.in
.include <bsd.port.mk>