aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/lives
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2008-04-09 23:51:53 +0800
committersat <sat@FreeBSD.org>2008-04-09 23:51:53 +0800
commitd7f2962d27039df3f7498620264c232801509fe1 (patch)
treee5b87e31c010dad60c3b703a655ce1ab9f19bf41 /multimedia/lives
parent41e89829f433b1b8d6e14d80f69de8381083b9db (diff)
downloadfreebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.tar.gz
freebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.tar.zst
freebsd-ports-gnome-d7f2962d27039df3f7498620264c232801509fe1.zip
- Update to 0.9.8.10
Diffstat (limited to 'multimedia/lives')
-rw-r--r--multimedia/lives/Makefile16
-rw-r--r--multimedia/lives/distinfo6
-rw-r--r--multimedia/lives/pkg-plist13
3 files changed, 22 insertions, 13 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 926ce3855ab4..5d96a977fbbb 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lives
-DISTVERSION= 0.9.8.6
-PORTREVISION= 3
+DISTVERSION= 0.9.8.10
CATEGORIES= multimedia
MASTER_SITES= http://www.xs4all.nl/%7Esalsaman/lives/current/ CENKES
DISTNAME= LiVES-${DISTVERSION}
@@ -29,6 +28,7 @@ LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick \
x264.50:${PORTSDIR}/multimedia/x264
BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ mencoder:${PORTSDIR}/multimedia/mencoder \
sox:${PORTSDIR}/audio/sox \
transcode:${PORTSDIR}/multimedia/transcode \
xmms:${PORTSDIR}/multimedia/xmms \
@@ -46,23 +46,25 @@ USE_GNOME= gtk20
USE_GETTEXT= yes
USE_GHOSTSCRIPT_RUN= yes
USE_SDL= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -g -fPIC
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -fPIC
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
LC_MESSAGES_NAMES= lives
+PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
post-patch:
@${REINPLACE_CMD} -e 's|i<FX_KEYS_MAX_VIRTUAL|i<prefs->rte_keys_virtual|' ${WRKSRC}/src/rte_window.c
- @${REINPLACE_CMD} -e '/test.*==/s|==|=|g' -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/LDFLAGS/s|-ldld||;s|-ldl||'\
+ @${REINPLACE_CMD} -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/LDFLAGS/s|-ldl||'\
${WRKSRC}/lives-plugins/weed-plugins/Makefile.in
@${REINPLACE_CMD} -e 's|-d alsa|-d oss|' ${WRKSRC}/src/main.c
@${REINPLACE_CMD} -e '/^SUBDIRS/s|weed-plugins||' ${WRKSRC}/lives-plugins/Makefile.in
- @${REINPLACE_CMD} -e '/^docdir/s|=.*|=${DOCSDIR}|' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^docdir/s|=.*|=${DOCSDIR}|;\
+ /update_with_plugins.*install/d' ${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC}/ -name Makefile.in |\
${XARGS} ${EGREP} -lm1 '(-O3|-fexpensive-optimizations)' |\
${XARGS} ${REINPLACE_CMD} -e 's|-O3||;s|-fexpensive-optimizations||'
+ @${REINPLACE_CMD} -e 's|\*\.py|*_encoder.py|' ${WRKSRC}/lives-plugins/marcos-encoders/Makefile.in
.include <bsd.port.mk>
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index 2f4763f3ead5..38c55ed5e6f9 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,3 +1,3 @@
-MD5 (LiVES-0.9.8.6.tar.bz2) = c73aed9b2da4fc74d51f9e92fae7439d
-SHA256 (LiVES-0.9.8.6.tar.bz2) = d84b555378d180109a01b6a7370551b2c316ffe31c7baabea4fbd005b22ebb1f
-SIZE (LiVES-0.9.8.6.tar.bz2) = 1724134
+MD5 (LiVES-0.9.8.10.tar.bz2) = 1203648fda17acd67d820c016c1622d4
+SHA256 (LiVES-0.9.8.10.tar.bz2) = 33172d06d8ce6a59d81e7c1a74081fc6f3d7260711b0b86a80ed81880caf3e34
+SIZE (LiVES-0.9.8.10.tar.bz2) = 1837914
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index beca722b6da7..d8bf56fad027 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -15,6 +15,7 @@ bin/ogm_encoder.py
bin/sendOSC
bin/smogrify
bin/theora_encoder.py
+share/applications/LiVES.desktop
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/BUGS
%%DOCSDIR%%/ChangeLog
@@ -57,6 +58,10 @@ bin/theora_encoder.py
%%DATADIR%%/plugins/effects/RFXscripts/flop.script
%%DATADIR%%/plugins/effects/RFXscripts/frame_calculator.script
%%DATADIR%%/plugins/effects/RFXscripts/gamma_change.script
+%%DATADIR%%/plugins/effects/RFXscripts/gen_blank_frames.script
+%%DATADIR%%/plugins/effects/RFXscripts/gen_clip_from_image.script
+%%DATADIR%%/plugins/effects/RFXscripts/gen_coloured_frames.script
+%%DATADIR%%/plugins/effects/RFXscripts/gen_text.script
%%DATADIR%%/plugins/effects/RFXscripts/hue_change.script
%%DATADIR%%/plugins/effects/RFXscripts/jumble.script
%%DATADIR%%/plugins/effects/RFXscripts/modulate.script
@@ -104,6 +109,10 @@ bin/theora_encoder.py
%%DATADIR%%/plugins/effects/rendered/flop
%%DATADIR%%/plugins/effects/rendered/frame_calculator
%%DATADIR%%/plugins/effects/rendered/gamma_change
+%%DATADIR%%/plugins/effects/rendered/gen_blank_frames
+%%DATADIR%%/plugins/effects/rendered/gen_clip_from_image
+%%DATADIR%%/plugins/effects/rendered/gen_coloured_frames
+%%DATADIR%%/plugins/effects/rendered/gen_text
%%DATADIR%%/plugins/effects/rendered/hue_change
%%DATADIR%%/plugins/effects/rendered/jumble
%%DATADIR%%/plugins/effects/rendered/modulate
@@ -158,10 +167,10 @@ bin/theora_encoder.py
%%DATADIR%%/themes/pinks/main.jpg
%%DATADIR%%/themes/sunburst/frame.jpg
%%DATADIR%%/themes/sunburst/main.jpg
-share/applications/LiVES.desktop
share/locale/cs/LC_MESSAGES/lives.mo
share/locale/de_DE/LC_MESSAGES/lives.mo
share/locale/fr/LC_MESSAGES/lives.mo
+share/locale/hu/LC_MESSAGES/lives.mo
share/locale/ja/LC_MESSAGES/lives.mo
share/locale/nl_NL/LC_MESSAGES/lives.mo
share/locale/pt_BR/LC_MESSAGES/lives.mo
@@ -185,8 +194,6 @@ share/pixmaps/lives.xpm
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%
@dirrmtry share/applications
-@dirrmtry share/locale/cs/LC_MESSAGES
-@dirrmtry share/locale/cs
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
@dirrmtry share/locale/nl_NL/LC_MESSAGES