aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/minitube
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/minitube
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'multimedia/minitube')
-rw-r--r--multimedia/minitube/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index c6c0100c4295..a92fb86e377f 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -11,18 +11,19 @@ COMMENT= TV-like client for YouTube
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake
+USES= qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= flaviotordini
USE_GL= gl
-USE_QT5= core dbus gui network phonon4 qml script sql widgets \
+USE_QT= core dbus gui network phonon4 qml script sql widgets \
buildtools_build imageformats_run sql-sqlite3_run
QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE} \
DEFINES+=APP_GOOGLE_API_KEY="${MINITUBE_GOOGLE_API_KEY}"
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USE= QT5=linguisttools_build
+NLS_USES= qt:5
+NLS_USE= QT=linguisttools_build
pre-everything::
@${CAT} ${PKGMESSAGE}