aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkvtoolnix/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-13 14:17:48 +0800
committerbapt <bapt@FreeBSD.org>2013-09-13 14:17:48 +0800
commit4c5a728c38c7dcb48a01960587a3e5d614c68708 (patch)
tree3f5daf46357bb5cc18da336365440d70796e99b3 /multimedia/mkvtoolnix/Makefile
parentea7e13c8353eff6d887c300b0d0f5b3af8160fcc (diff)
downloadfreebsd-ports-gnome-4c5a728c38c7dcb48a01960587a3e5d614c68708.tar.gz
freebsd-ports-gnome-4c5a728c38c7dcb48a01960587a3e5d614c68708.tar.zst
freebsd-ports-gnome-4c5a728c38c7dcb48a01960587a3e5d614c68708.zip
Use clang+libc++ when possible
Diffstat (limited to 'multimedia/mkvtoolnix/Makefile')
-rw-r--r--multimedia/mkvtoolnix/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index eebd8abc5b61..4b532eb262fa 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
USES= pkgconfig gettext iconv
USE_XZ= yes
-USE_GCC= yes
GNU_CONFIGURE= yes
USE_RAKE= yes
USE_RUBY= yes
@@ -42,6 +41,11 @@ MAN1= mkvextract.1 mkvinfo.1 mkvmerge.1 mkvpropedit.1
OPTIONS_DEFINE= WXGTK FLAC CURL
OPTIONS_DEFAULT=WXGTK FLAC CURL
+_CCVERSION= ${CC} --version
+.if !${_CCVERSION:MCLANG} || ${OSVERSION} < 1000053
+USE_GCC= yes
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"