aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkvtoolnix/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-08 01:48:43 +0800
committerbapt <bapt@FreeBSD.org>2014-05-08 01:48:43 +0800
commitde21556668cd298a70eb4a9405b8bc48641f09da (patch)
tree74a0a3d7457a7bd6ebc3f9fce003061285b55173 /multimedia/mkvtoolnix/Makefile
parent5361a8e164f055930b8c5be2fd2490f840b35dab (diff)
downloadfreebsd-ports-gnome-de21556668cd298a70eb4a9405b8bc48641f09da.tar.gz
freebsd-ports-gnome-de21556668cd298a70eb4a9405b8bc48641f09da.tar.zst
freebsd-ports-gnome-de21556668cd298a70eb4a9405b8bc48641f09da.zip
Update to 6.9.1
Disable CURL options by default it is not clang+libc+++boost friendly Switch default wx to wx 3.0 Add missing depencencies Allow to parallel build
Diffstat (limited to 'multimedia/mkvtoolnix/Makefile')
-rw-r--r--multimedia/mkvtoolnix/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index f027dfa1f8a7..315a2d13a9a4 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mkvtoolnix
-PORTVERSION= 6.7.0
-PORTREVISION= 1
+PORTVERSION= 6.9.1
CATEGORIES= multimedia audio
MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/ \
CRITICAL
@@ -16,14 +15,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg \
- libboost_regex.so:${PORTSDIR}/devel/boost-libs \
libebml.so:${PORTSDIR}/textproc/libebml \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs \
libmatroska.so:${PORTSDIR}/multimedia/libmatroska
-USES= pkgconfig gettext iconv compiler:c++11-lib
-USE_XZ= yes
+USES= pkgconfig gettext iconv compiler:c++11-lib tar:xz
GNU_CONFIGURE= yes
-USE_RAKE= yes
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -36,12 +33,13 @@ CONFIGURE_ARGS= --disable-qt \
--with-boost-regex=boost_regex
OPTIONS_DEFINE= WXGTK FLAC CURL
-OPTIONS_DEFAULT=WXGTK FLAC CURL
+OPTIONS_DEFAULT=WXGTK FLAC
BROKEN_sparc64= Does not install on sparc64
OPTIONS_SUB= yes
-WXGTK_USE= WX=2.8+
+WXGTK_USES= desktop-file-utils shared-mime-info
+WXGTK_USE= wx=3.0
WXGTK_CONFIGURE_ENABLE= gui
WX_UNICODE= yes
WX_CONF_ARGS= absolute
@@ -56,9 +54,9 @@ MAKE_ENV+= V=1
.endif
do-build:
- @(cd ${WRKSRC}/; unset PREFIX; ${RAKE_BIN})
+ @(cd ${WRKSRC}/; unset PREFIX; ./drake ${_MAKE_JOBS})
do-install:
- @(cd ${WRKSRC}/; unset PREFIX; ${RAKE_BIN} ${MAKE_ARGS} install)
+ @(cd ${WRKSRC}/; unset PREFIX; ./drake ${_MAKE_JOBS} ${MAKE_ARGS} install)
.include <bsd.port.mk>