aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkvtoolnix/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-01-08 23:11:53 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-01-08 23:11:53 +0800
commitf163d0af570663fe5f27bae049052796906c7c0b (patch)
tree50f7dbdee1c2b72adba37ac731b788587882f16d /multimedia/mkvtoolnix/Makefile
parentd0b4fae7ddb918c5db21d1c40c927c157e80de20 (diff)
downloadfreebsd-ports-gnome-f163d0af570663fe5f27bae049052796906c7c0b.tar.gz
freebsd-ports-gnome-f163d0af570663fe5f27bae049052796906c7c0b.tar.zst
freebsd-ports-gnome-f163d0af570663fe5f27bae049052796906c7c0b.zip
Update to 4.4.0. The project has moved from make to rake, therefore use
USE_RUBY and USE_RAKE with special do-build and do-install targets. Also add a few more mirrors.
Diffstat (limited to 'multimedia/mkvtoolnix/Makefile')
-rw-r--r--multimedia/mkvtoolnix/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 0e65e9e385aa..140e5e15dd27 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= mkvtoolnix
-PORTVERSION= 4.2.0
+PORTVERSION= 4.4.0
CATEGORIES= multimedia audio
-MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/
+MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/ \
+ CRITICAL
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Tools to extract from/get info about/create Matroska media streams
@@ -27,9 +28,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
+USE_RAKE= yes
+USE_RUBY= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
@@ -41,6 +43,7 @@ CONFIGURE_ARGS= --enable-lzo --enable-bz2 --disable-qt \
--with-boost-regex=boost_regex
MAKE_JOBS_SAFE= yes
+MANLANG= "" ja zh_CN
MAN1= mkvextract.1 mkvinfo.1 mkvmerge.1 mkvpropedit.1
OPTIONS= WXGTK "build wxGTK2 based GUI" on
@@ -69,4 +72,10 @@ PLIST_SUB+= GUI="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|"-O3"|""|g' ${WRKSRC}/configure
+do-build:
+ @(cd ${WRKSRC}/; ${SETENV} ${MAKE_ENV} ${RAKE_BIN})
+
+do-install:
+ @(cd ${WRKSRC}/; ${SETENV} ${MAKE_ENV} ${RAKE_BIN} install)
+
.include <bsd.port.post.mk>