aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/motion
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-10-03 21:37:26 +0800
committerpav <pav@FreeBSD.org>2007-10-03 21:37:26 +0800
commitb57218ae0552dc99085ab8a34b1715fe8f98dd74 (patch)
tree9d8fb045e5a623e989dda51b2722b1ebd6602f38 /multimedia/motion
parent6e671795eee5e69737609bad7615d64365f0981c (diff)
downloadfreebsd-ports-gnome-b57218ae0552dc99085ab8a34b1715fe8f98dd74.tar.gz
freebsd-ports-gnome-b57218ae0552dc99085ab8a34b1715fe8f98dd74.tar.zst
freebsd-ports-gnome-b57218ae0552dc99085ab8a34b1715fe8f98dd74.zip
- Fix the ffmpeg problem on runtime too
Submitted by: Angel Carpintero <ack@telefonica.net> (maintainer)
Diffstat (limited to 'multimedia/motion')
-rw-r--r--multimedia/motion/Makefile4
-rw-r--r--multimedia/motion/distinfo6
-rw-r--r--multimedia/motion/files/patch-ffmpeg.c10
3 files changed, 5 insertions, 15 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index b497d826be98..4178ab34877f 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -7,13 +7,13 @@
PORTNAME= motion
PORTVERSION= 3.2.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= motion
PATCH_SITES= http://www.lavrsen.dk/twiki/pub/Motion/FreeBSDPatch/
-PATCHFILES= motion-3.2.8.port-freebsd.diff.gz
+PATCHFILES= motion-3.2.8.port-freebsd.ffmpeg-2007-09-14.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ack@telefonica.net
diff --git a/multimedia/motion/distinfo b/multimedia/motion/distinfo
index e43c0a713c3e..9096855482d2 100644
--- a/multimedia/motion/distinfo
+++ b/multimedia/motion/distinfo
@@ -1,6 +1,6 @@
MD5 (motion-3.2.8.tar.gz) = 9d273df173675f1c523fd092e188dc24
SHA256 (motion-3.2.8.tar.gz) = 8f695660380edf94cdbe7e580a3146bf8c20bcfe3a47643eb9de95e49f691889
SIZE (motion-3.2.8.tar.gz) = 394005
-MD5 (motion-3.2.8.port-freebsd.diff.gz) = 46987ff9d16c4fbd1d2ca227f0934474
-SHA256 (motion-3.2.8.port-freebsd.diff.gz) = b3cbbc4111ad8ef4e8453e7e526765e7bf5fd3da9037ff4b8b0ece259772be5c
-SIZE (motion-3.2.8.port-freebsd.diff.gz) = 2925
+MD5 (motion-3.2.8.port-freebsd.ffmpeg-2007-09-14.diff.gz) = 173635ba96b0dd73c6261d693689b1ad
+SHA256 (motion-3.2.8.port-freebsd.ffmpeg-2007-09-14.diff.gz) = e9becdb4fdc78ae9a3a63621dc0787d17aa8e0163b8d5695da9aa437e15505a8
+SIZE (motion-3.2.8.port-freebsd.ffmpeg-2007-09-14.diff.gz) = 3731
diff --git a/multimedia/motion/files/patch-ffmpeg.c b/multimedia/motion/files/patch-ffmpeg.c
deleted file mode 100644
index 524de23f452d..000000000000
--- a/multimedia/motion/files/patch-ffmpeg.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ffmpeg.c.orig 2007-07-18 09:18:05.000000000 +0200
-+++ ffmpeg.c 2007-10-03 01:05:23.000000000 +0200
-@@ -126,6 +126,7 @@
- /* ffmpeg_init initializes for libavformat. */
- void ffmpeg_init()
- {
-+ URLProtocol file_protocol;
- av_register_all();
- av_log_set_callback( (void *)ffmpeg_avcodec_log );
-