aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mpeg4ip
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2009-08-12 17:17:51 +0800
committermm <mm@FreeBSD.org>2009-08-12 17:17:51 +0800
commitc96652fa85f09edf7bae389a27b0a3e23672d867 (patch)
tree5b249ff02a6c101576801fe18b020256547510e8 /multimedia/mpeg4ip
parent8f77eb03e3bd7fb1bbba7dac3582979b6410731d (diff)
downloadfreebsd-ports-gnome-c96652fa85f09edf7bae389a27b0a3e23672d867.tar.gz
freebsd-ports-gnome-c96652fa85f09edf7bae389a27b0a3e23672d867.tar.zst
freebsd-ports-gnome-c96652fa85f09edf7bae389a27b0a3e23672d867.zip
- Fix build error with ffmpeg 0.5
- Add MAKE_JOBS_SAFE for SMP compilation - Bump portrevision
Diffstat (limited to 'multimedia/mpeg4ip')
-rw-r--r--multimedia/mpeg4ip/Makefile6
-rw-r--r--multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.cpp23
-rw-r--r--multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.h13
3 files changed, 40 insertions, 2 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 84e8426621b6..3632519f3581 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpeg4ip
PORTVERSION= 1.6.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= LOCAL/ahze
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
@@ -33,6 +33,7 @@ RUN_DEPENDS= mpeg4ip-libmp4v2>=1.6.1:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
USE_GNOME= gtk20
USE_SDL= sdl
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/SDL -I${LOCALBASE}/include/ffmpeg -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
@@ -174,6 +175,7 @@ post-patch:
s|mp4v2/mp4.h|mp4.h|; \
s|<malloc.h>|<stdlib.h>|; \
s|<avcodec.h>|<libavcodec/avcodec.h>|; \
+ s|<swscale.h>|<libswscale/swscale.h>|; \
s|<strstream.h>|<iostream>|'
# replacing distfile's libs with ports' versions
# SDL related fixes
@@ -191,7 +193,7 @@ post-patch:
${WRKSRC}/doc/mp4v2/Makefile.in
# objformat
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
- @${REINPLACE_CMD} -e 's|$${enable_ffmpeg}/lib/libavcodec.a|-lavcodec|g' \
+ @${REINPLACE_CMD} -e 's|$${enable_ffmpeg}/lib/libavcodec.a|-lavcodec -lswscale|g' \
${WRKSRC}/configure
post-install:
diff --git a/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.cpp b/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.cpp
new file mode 100644
index 000000000000..6f94ad60d072
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.cpp
@@ -0,0 +1,23 @@
+--- player/plugin/video/ffmpeg/ffmpeg.cpp 2007-07-02 22:26:03.000000000 +0200
++++ player/plugin/video/ffmpeg/ffmpeg.cpp 2008-10-10 23:01:19.519476374 +0200
+@@ -585,10 +585,16 @@ static int ffmpeg_decode (codec_data_t *
+ from.data[ix] = ffmpeg->m_picture->data[ix];
+ from.linesize[ix] = ffmpeg->m_picture->linesize[ix];
+ }
+-
+- img_convert(&to, PIX_FMT_YUV420P,
+- &from, ffmpeg->m_c->pix_fmt,
+- ffmpeg->m_c->width, ffmpeg->m_c->height);
++#ifdef HAVE_FFMPEG_INSTALLED
++ SwsContext *pSWSCtx;
++ pSWSCtx = sws_getContext(ffmpeg->m_c->width, ffmpeg->m_c->height,
++ ffmpeg->m_c->pix_fmt,
++ ffmpeg->m_c->width, ffmpeg->m_c->height,
++ PIX_FMT_YUV420P, SWS_BICUBIC, 0, 0, 0);
++ sws_scale(pSWSCtx, from.data, from.linesize, 0, ffmpeg->m_c->height,
++ to.data, to.linesize);
++ sws_freeContext(pSWSCtx);
++#endif
+ ffmpeg->m_vft->video_filled_buffer(ffmpeg->m_ifptr,
+ ffmpeg->have_cached_ts ?
+ ffmpeg->cached_ts : ts);
diff --git a/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.h b/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.h
new file mode 100644
index 000000000000..e051c63d0a31
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-player-plugin-video-ffmpeg-ffmpeg.h
@@ -0,0 +1,13 @@
+--- player/plugin/video/ffmpeg/ffmpeg.h.orig 2007-07-02 22:26:03.000000000 +0200
++++ player/plugin/video/ffmpeg/ffmpeg.h 2009-08-12 11:11:12.005600087 +0200
+@@ -28,8 +28,10 @@
+ extern "C" {
+ #ifdef HAVE_FFMPEG_INSTALLED
+ #include <ffmpeg/avcodec.h>
++#include <ffmpeg/swscale.h>
+ #else
+ #include <avcodec.h>
++#include <swscale.h>
+ #endif
+ }
+ #include <mp4av.h>
1e243288e2383421c00346275f0acfa9b6271595'>Fix MOVED entrybapt2015-02-031-1/+1 * [CHANGE CATEGORY] sysutils/currtime: deskutils->sysutilsbofh2015-02-031-0/+1 * - merge japanese/xlockmore into x11/xlockmorejgh2015-02-031-0/+1 * Remove expired ports:rene2015-02-031-0/+6 * - Remove owncloud-csync, it's been merged in net/mirall, please use thatmadpilot2015-02-011-0/+1 * Remove lines corresponding to recently restored ports.linimon2015-01-301-3/+0 * Remove expired ports:rene2015-01-291-0/+8 * textproc/py-charade: project has been merged back into textproc/py-chardetwg2015-01-281-0/+1 * Add devel/actor-framework.vanilla2015-01-191-0/+1 * - Move devel/p5-perlbrew to devel/p5-App-perlbrewsunpoet2015-01-191-0/+1 * - Create separate QT4 and QT5 ports for www/qupzillamadpilot2015-01-191-0/+1 * net/fspd: reviverene2015-01-181-1/+0 * Remove expired ports:rene2015-01-171-0/+3 * Removed port games/vdrift-datamarino2015-01-171-0/+1 * - Update devel/qca to version 2.1.0tijl2015-01-131-0/+3 * Remove multimedia/mplayer-fontsriggs2015-01-111-0/+1 * Re-create comms/linpskshurd2015-01-101-1/+0 * Ressurect klog - a simple QSO logger for Amateur radioshurd2015-01-071-1/+0 * Ressurect comms/qtel as a slave port of comms/svxlinkshurd2015-01-071-1/+0 * Remove expired ports:rene2015-01-071-0/+8 * - Move devel/rubygem-little_plugger to devel/rubygem-little-pluggersunpoet2015-01-061-0/+1 * Resurrect science/mpb, pass maintainership to PR submitter.rene2015-01-041-1/+0 * Remove expired ports:rene2015-01-011-0/+4 * egalax was reinstated in 375733 by glebius.linimon2015-01-011-1/+0 * Remove this expired port too...rene2015-01-011-0/+1 * Remove expired ports:rene2015-01-011-0/+32 * Remove expired port:rene2015-01-011-0/+1 * Fix MOVEDgrembo2014-12-311-1/+1 * Rename biology/ncbi-blast to biology/ncbi-blast+grembo2014-12-311-0/+1 * - rename deskutils/xpad-current to deskutils/xpadjgh2014-12-311-0/+1 * devel/py-checkmanifest: Rename port, Update to 0.22koobs2014-12-291-0/+1 * Renamed for better naminggblach2014-12-291-0/+1 * Replace multimedia/ffmpeg24 with ffmpeg25riggs2014-12-271-0/+1 * games/secretmaryochronicles: remove this expired port toorene2014-12-271-0/+1 * Remove expired ports:rene2014-12-271-0/+3 * Remove imlib1bapt2014-12-261-0/+1 * Remove fpc-imlib and fpc-gnome1bapt2014-12-251-0/+2 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-0/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-0/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-0/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-1/+2 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-0/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-0/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-251-1/+2 * Remove abandonware blocking decomission of imlibbapt2014-12-251-0/+1 * Abandonware (1999) no support for modern graphics librariesbapt2014-12-251-0/+1 * Was added just for hugin which now support libpano13bapt2014-12-251-0/+1 * No proper support for png 1.5, abandoned upstream since 2003bapt2014-12-251-0/+1 * Fix wordingbapt2014-12-251-1/+1 * Remove now useless gnomehier, pkg handles automatically the directories wherebapt2014-12-251-0/+1 * Remove some resurected portsantoine2014-12-251-2/+0 * No more upstream, no more public distfile, no proper support for modern pngbapt2014-12-241-0/+1 * - rename www/neon29 to www/neon and update to neon-0.30.1ohauer2014-12-241-0/+1 * Forgot to note port removal on MOVEDfeld2014-12-211-0/+2 * x11-servers/xorg-server: Update to 1.14dumbbell2014-12-201-0/+5 * Remove ports of obsolete and unmaintained upstream llvm/clang 3.2.brooks2014-12-191-0/+2 * Remove revived print/lgrindpawel2014-12-191-1/+0 * Correct spelling, and lint.mat2014-12-161-1/+1 * Remove expired ports:rene2014-12-161-0/+2 * - Update to 1.13, announce message:nemysis2014-12-151-0/+1 * Cleanup the xerces-c* messbapt2014-12-121-0/+2 * NTP is now release candidate with 4.2.7p484.cy2014-12-121-0/+1 * Revive ports: sysutils/boxbackup, sysutils/boxbackup-develpi2014-12-111-2/+0 * www/twig-php: Remove the port as obsolete and being replaced by www/pear-twig...robak2014-12-091-0/+1 * Add a forgotten port.mat2014-12-081-0/+1 * - Resurrect, unbreak, cleanup Makefile, define LICENSE (LGPL21)danfe2014-12-071-1/+0 * Remove port databases/postgresql93-plv8js (avoids broken index)marino2014-12-071-0/+1 * - Remove ports-mgmt/pkg-plist, it was resurrectedak2014-12-071-1/+0 * - Rename editors/texmakerx to editors/texstudio and update it to 2.8.6makc2014-12-071-0/+1 * Improve wording of some entries; explicitly mention cases when I've tried todanfe2014-12-071-7/+7 * Remove expired port:rene2014-12-061-0/+1 * - Resurrect, unbreak, stagify, modernize Makefiledanfe2014-12-061-1/+0 * Remove devel/rubygem-rb-readline, it's not neededantoine2014-12-051-0/+1 * - Reflect resurrection of graphics/seom and graphics/yukondanfe2014-12-051-6/+4 * Update GNOME to 3.14.2.kwm2014-12-031-0/+1 * Mark the rename from sw-hunspell to sv-hunspell (this also helps portscout tobapt2014-12-031-0/+1 * Replaced by newer versionbapt2014-12-021-0/+1 * Remove now unused librarybapt2014-12-021-0/+1 * Remove expired ports:rene2014-12-021-0/+7 * Remove expired ports:rene2014-11-291-0/+11 * Remove print/pdfjam, it's included in texlive-baseantoine2014-11-281-0/+1 * Remove print/latexmk, it's included in texlive-baseantoine2014-11-281-0/+1 * Remote duplicate portantoine2014-11-271-0/+1 * Remove folks04, it no longer used after the GNOME 3 import.kwm2014-11-261-0/+1 * - Merge EFL libraries into devel/efl and update to 1.12.0gblach2014-11-251-0/+56 * Reomove expired port:rene2014-11-251-0/+1 * Remove net/p5-SOAP-Transport-TCP, it has been integrated into net/p5-SOAP-Lite.mat2014-11-251-2/+1 * Abandoned upstream, incomplete, not depend onbapt2014-11-241-0/+1 * graphics/linux-c6-gdk-pixbuf: rename to -pixbuf2xmj2014-11-241-0/+1 * Document the removal of sysutils/firstboot-growfs.cperciva2014-11-241-0/+1 * Resurrect devel/mico, in order to restore OpenFOAM.thierry2014-11-241-1/+0 * Resurrect print/ghostscript7{,-commfont,-jpnfont,-korfont,-nox11}.hrs2014-11-231-5/+0 * Revive graphics/pintariggs2014-11-221-1/+0 * Resurrect editors/psgml.hrs2014-11-221-1/+0 * - update to 1.1.0jgh2014-11-211-0/+1 * - Rename net-im/tg to net-im/telegramkmoore2014-11-201-0/+1 * Remove expired port:rene2014-11-201-0/+1 * Revive Qucs, now that it no longer depends on Qt3.joerg2014-11-201-1/+0 * Remove gnome2 only abandonwarebapt2014-11-201-0/+1 * Abandonware, not working anymorebapt2014-11-191-0/+1 * Abandonwarebapt2014-11-191-0/+1 * Does not work anymorebapt2014-11-191-0/+1 * Remove: does not run anymorebapt2014-11-191-0/+1 * Remove libzvt, it is not used anymore by anything in the ports treebapt2014-11-191-0/+1 * Remove: abandonware, depends on non existing USE_GNOME componentsbapt2014-11-191-0/+1 * Remove: abandonware, depends on non existing USE_GNOME componentsbapt2014-11-191-0/+1 * Remove: abandonware, depends on non existing USE_GNOME componentsbapt2014-11-191-0/+1 * Remove: abandonware, depends on non existing USE_GNOME componentsbapt2014-11-191-0/+1 * - Remove duplicate port of net-im/tgkmoore2014-11-191-0/+1 * The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.kwm2014-11-191-0/+43 * Remove sysutils/cfengine36-rc because cfengine 3.6.2 has gone GA.cy2014-11-191