aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mpeg4ip
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-04 13:33:42 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-04 13:33:42 +0800
commit9bbc5838ebfc13a8e275dd681bcdab14638ef4c2 (patch)
treef79e20b06047216548c6909493f270f3620729b9 /multimedia/mpeg4ip
parent902ea100b42f59e860c95cc0d2142858d4f966e9 (diff)
downloadfreebsd-ports-gnome-9bbc5838ebfc13a8e275dd681bcdab14638ef4c2.tar.gz
freebsd-ports-gnome-9bbc5838ebfc13a8e275dd681bcdab14638ef4c2.tar.zst
freebsd-ports-gnome-9bbc5838ebfc13a8e275dd681bcdab14638ef4c2.zip
Fix build on -HEAD. Committed on behalf of lioux who is having machine
problems. PR: ports/57637 Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'multimedia/mpeg4ip')
-rw-r--r--multimedia/mpeg4ip/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 268fe76ea1ab..12d0522229e2 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -16,10 +16,10 @@ COMMENT= Standards-based system to encode, stream and play MPEG-4 audio/video
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
pkg-config:${PORTSDIR}/devel/pkgconfig
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
USE_GNOME= gtk20
USE_GMAKE= yes
+USE_SDL= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} \
@@ -30,8 +30,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
DOC_FILES= COPYING README doc/MPEG4IP_Guide.pdf
MAN1= gmp4player.1 mp4creator.1 mp4encode.1 mp4live.1
@@ -93,7 +91,7 @@ post-extract:
.include <bsd.port.pre.mk>
post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} -n 10 \
+ @${FIND} ${WRKSRC} -type f -name "*.[ch]" -or -name "*.cpp" | ${XARGS} -n 10 \
${REINPLACE_CMD} -e \
's|stdint\.h|inttypes.h|;s|malloc\.h|stdlib.h|'
# replacing distfile's libs with ports' versions