aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer/Makefile.shared
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-04-27 22:22:25 +0800
committerriggs <riggs@FreeBSD.org>2014-04-27 22:22:25 +0800
commita8f04f3576566f7cf1b5d2e440257ef7437d460c (patch)
tree94111a7ea6e11cde62f01ccd92a2d962cca278ae /multimedia/mplayer/Makefile.shared
parent59ba7bdaa32261e5485d5d971833c1216e25c08f (diff)
downloadfreebsd-ports-gnome-a8f04f3576566f7cf1b5d2e440257ef7437d460c.tar.gz
freebsd-ports-gnome-a8f04f3576566f7cf1b5d2e440257ef7437d460c.tar.zst
freebsd-ports-gnome-a8f04f3576566f7cf1b5d2e440257ef7437d460c.zip
- Sync with upstream snapshot of 2014-04-18
- General Makefile cleanup - Fix x11 dependency handling (xproto was missing) - Builds with LOCALBASE != PREFIX should work everywhere now - Remove support for esd unconditionally - mplayer: default build enables fribidi option, so smplayer and smtube packages from official FreeBSD package repos will work out of the box - Add profiling option (disabled by default) - Remove WITH_LANG knob (was unused for a long time anyway) - Chase libbluray shared lib version bump from ports/188573 Approved by: thierry (mentor)
Diffstat (limited to 'multimedia/mplayer/Makefile.shared')
-rw-r--r--multimedia/mplayer/Makefile.shared14
1 files changed, 8 insertions, 6 deletions
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 8edc0befa86e..9992dba85852 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -4,15 +4,14 @@
#
# $FreeBSD$
-MPLAYER_SNAPSHOT_DATE= 2013-12-23
+MPLAYER_SNAPSHOT_DATE= 2014-04-18
MPLAYER_PORT_VERSION= 1.1.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
CATEGORIES?= multimedia audio
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= riggs/${PORTNAME}
DISTNAME= mplayer-${MPLAYER_PORT_VERSION:S/.r/./g}
WRKSRC= ${WRKDIR}/mplayer-export-${MPLAYER_SNAPSHOT_DATE}
-PROJECTHOST= bsdistfiles
-
MAINTAINER?= riggs@FreeBSD.org
LICENSE= GPLv2
@@ -22,8 +21,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
BUILD_DEPENDS= ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
-USES= gmake iconv ncurses
-USE_XZ= yes
+USES= gmake iconv ncurses tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -36,7 +34,10 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-alsa \
--disable-bitmap-font \
--disable-crystalhd \
+ --disable-esd \
--disable-faad \
+ --disable-ggi \
+ --disable-ggiwmh \
--disable-liba52 \
--disable-libbs2b \
--disable-libilbc \
@@ -46,6 +47,7 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-joystick \
--disable-mad \
--disable-mp3lib \
+ --disable-libmpeg2 \
--disable-nemesi \
--disable-speex \
--enable-ass-internal