aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer2
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-22 01:56:33 +0800
committerwg <wg@FreeBSD.org>2013-10-22 01:56:33 +0800
commit19df2b97bc3621a8d5097dd0c0d326c0d9851853 (patch)
tree8d42cb2df2160aba7a4626c47d1e2946485995fe /multimedia/mplayer2
parente839effdb652dd1de67fac5ffafb8b078e30e478 (diff)
downloadfreebsd-ports-gnome-19df2b97bc3621a8d5097dd0c0d326c0d9851853.tar.gz
freebsd-ports-gnome-19df2b97bc3621a8d5097dd0c0d326c0d9851853.tar.zst
freebsd-ports-gnome-19df2b97bc3621a8d5097dd0c0d326c0d9851853.zip
multimedia/mplayer2: use ffmpeg instead of ffmpeg1
- Use ffmpeg instead of ffmpeg1 Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'multimedia/mplayer2')
-rw-r--r--multimedia/mplayer2/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index a84641157af0..e3551d5667f5 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mplayer2
PORTVERSION= ${MPLAYER2_PORT_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= LOCAL/gblach/
@@ -13,10 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
dvdread:${PORTSDIR}/multimedia/libdvdread
-BUILD_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1 \
+BUILD_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
python3:${PORTSDIR}/lang/python3 \
rst2man:${PORTSDIR}/textproc/py-docutils
-RUN_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1
+RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
USE_XZ= yes
USES= gmake iconv ncurses pkgconfig
@@ -25,10 +26,8 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
TMPDIR="${WRKSRC}"
CONFIGURE_ARGS= --cc=${CC} \
- --extra-cflags='-I${LOCALBASE}/include/ffmpeg1 \
- -I${LOCALBASE}/include/portaudio2' \
- --extra-ldflags='-L${LOCALBASE}/lib/ffmpeg1 -lavresample1 \
- -L${LOCALBASE}/lib/portaudio2' \
+ --extra-cflags='-I${LOCALBASE}/include/portaudio2' \
+ --extra-ldflags='-lavresample -L${LOCALBASE}/lib/portaudio2' \
--mandir=${PREFIX}/man \
--enable-libavresample \
--disable-alsa \
@@ -287,12 +286,6 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
@${REINPLACE_CMD} \
- -e 's/libavutil/libavutil1/' \
- -e 's/libavcodec/libavcodec1/' \
- -e 's/libavformat/libavformat1/' \
- -e 's/libswscale/libswscale1/' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} \
-e 's|/dev/acd0|${WITH_CDROM_DEVICE}|' \
-e 's|/usr/local|${LOCALBASE}|' \
-e 's|-lbz2|/usr/lib/libbz2.so|' \