aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer2
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-30 19:29:19 +0800
committermarino <marino@FreeBSD.org>2013-10-30 19:29:19 +0800
commit07eb264eece5905d0d7ba313efeff2923534f5be (patch)
treefe6c0e88b131a8e84f151427011778a7935d1951 /multimedia/mplayer2
parent9315bd082085b0f3512f758cb3701d1cc2bf2aef (diff)
downloadfreebsd-ports-gnome-07eb264eece5905d0d7ba313efeff2923534f5be.tar.gz
freebsd-ports-gnome-07eb264eece5905d0d7ba313efeff2923534f5be.tar.zst
freebsd-ports-gnome-07eb264eece5905d0d7ba313efeff2923534f5be.zip
multimedia/mplayer2: fix configure failure, indirect linking
As seen when using gcc48 as the ports compiler (and on DragonFly), mplayer2 was misconfigured. The avresample library doesn't exist during configuration, thus it will fail when using a modern linker that complains that the library isn't found. Moving -lavresample from extra-ldflags to extra-libs fixes the problem on both FreeBSD+gcc48 and DragonFly Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'multimedia/mplayer2')
-rw-r--r--multimedia/mplayer2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index d32c35fd5488..40d67e015d49 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -27,7 +27,8 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
TMPDIR="${WRKSRC}"
CONFIGURE_ARGS= --cc=${CC} \
--extra-cflags='-I${LOCALBASE}/include/portaudio2' \
- --extra-ldflags='-lavresample -L${LOCALBASE}/lib/portaudio2' \
+ --extra-libs='-lavresample' \
+ --extra-ldflags='-L${LOCALBASE}/lib/portaudio2' \
--mandir=${PREFIX}/man \
--enable-libavresample \
--disable-alsa \