aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-09-25 04:43:22 +0800
committermnag <mnag@FreeBSD.org>2005-09-25 04:43:22 +0800
commit6f75bbe12b3dbfdc188ef908a316770878e04d6b (patch)
treec17548248f61664ff5288093767ca35f6f8426b7 /multimedia/mplayer
parentf1dc083962b37b8a09b850dd513c0265d956ddbd (diff)
downloadfreebsd-ports-gnome-6f75bbe12b3dbfdc188ef908a316770878e04d6b.tar.gz
freebsd-ports-gnome-6f75bbe12b3dbfdc188ef908a316770878e04d6b.tar.zst
freebsd-ports-gnome-6f75bbe12b3dbfdc188ef908a316770878e04d6b.zip
Add support to DTS decoding
PR: ports/86473 Submitted by: bh@izb.knu.ac.kr Approved by: pav (mentor), riggs@rrr.de (maintainer)
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 2ef299a5e6ab..1e3e509034c0 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -241,6 +241,9 @@
# WITH_XMMS
# default: autodetect
#
+# WITH_DTS
+# default: autodetect
+#
# WITH_LANG
# default: en
# Enables language support bg, cz, de, dk, en, es, fr, gr, hu, it, ko, nl, no, pl, pt_BR, ro, ru, sk, tr, uk, zh
@@ -442,6 +445,10 @@ WITH_XVID= yes
WITH_XMMS= yes
.endif
+.if exists(${LOCALBASE}/lib/libdts.a)
+WITH_DTS= yes
+.endif
+
.if exists(${LOCALBASE}/lib/liblzo.so)
WITH_LZO= yes
.endif
@@ -737,6 +744,11 @@ CONFIGURE_ARGS+= --enable-xmms
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
.endif
+.if defined(WITH_DTS)
+CONFIGURE_ARGS+= --enable-libdts
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts.a:${PORTSDIR}/multimedia/libdts
+.endif
+
.if defined(WITH_FREETYPE)
CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
--enable-freetype