aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-09-03 10:46:49 +0800
committerlioux <lioux@FreeBSD.org>2002-09-03 10:46:49 +0800
commitb9ff5234b278e2c336a3e477f772c38288f4fe79 (patch)
treec975fe5cb1e1002a57c6395b81bc96b4864a93bf /multimedia/mplayer
parentbbbbae8b914fbb665c2f9f4e8504c497abe8ebee (diff)
downloadfreebsd-ports-gnome-b9ff5234b278e2c336a3e477f772c38288f4fe79.tar.gz
freebsd-ports-gnome-b9ff5234b278e2c336a3e477f772c38288f4fe79.tar.zst
freebsd-ports-gnome-b9ff5234b278e2c336a3e477f772c38288f4fe79.zip
Deploy USE_GNOMENG infrastructure
PR: 42349 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index fbc0e1ee748a..2877ffdd2726 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-extraincdir=${LOCALBASE}/include
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
MAN1= mplayer.1
MLINKS= mplayer.1 mencoder.1
MANCOMPRESSED= no
@@ -76,12 +77,13 @@ WITH_XANIM= yes
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
-.if defined(HAVE_GTK)
+.if ${HAVE_GNOME:Mgtk12}!=""
WITH_GUI= yes
.endif
.if defined(WITH_GUI)
-USE_GTK= yes
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
CONFIGURE_ARGS+= --enable-gui
.endif
@@ -160,7 +162,7 @@ pre-everything::
@${ECHO_MSG} "You can enable additional compilation optimizations"
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-.if !defined(WITH_GUI) && !defined(HAVE_GTK)
+.if !defined(WITH_GUI) && ${HAVE_GNOME:Mgtk12}==""
@${ECHO_MSG} "You can enable GTK GUI by defining WITH_GUI."
.endif
.if !defined(WITH_DVD)