aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-17 16:50:21 +0800
committermiwi <miwi@FreeBSD.org>2009-05-17 16:50:21 +0800
commit5d4ad0a7bae3a02c0102ac19913cfcdc87613178 (patch)
treea1f4d1912f3699d1f904701aa4e863e6fb110bc3 /multimedia/mplayer
parent5a02964bbe1eaeed1955d207350f3b5e97ef428e (diff)
downloadfreebsd-ports-gnome-5d4ad0a7bae3a02c0102ac19913cfcdc87613178.tar.gz
freebsd-ports-gnome-5d4ad0a7bae3a02c0102ac19913cfcdc87613178.tar.zst
freebsd-ports-gnome-5d4ad0a7bae3a02c0102ac19913cfcdc87613178.zip
- Add support for XvMC acceleration
PR: 134587 Submitted by: Hajimu UMEMOTO <ume@mahoroba.org> Approved by: maintainer implicit
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index a2174d87ad2a..2a24500dcc90 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -24,6 +24,7 @@ OPTIONS+= X11DGA "X11 video drivers: DGA" on
OPTIONS+= X11GL "X11 video drivers: OpenGL" on
OPTIONS+= X11XIN "X11 video drivers: Xinerama" on
OPTIONS+= X11VM "X11 VidMode support" on
+OPTIONS+= X11XVMC "Enable XvMC acceleration" off
OPTIONS+= GUI "Enable GTK2 graphical user interface with X11" on
OPTIONS+= SDL "Enable SDL video output" off
OPTIONS+= VIDIX "Enable VIDIX video output on supported archs" on
@@ -150,6 +151,10 @@ USE_XORG+= xxf86vm
.else
CONFIGURE_ARGS+=--disable-vm
.endif
+.if defined(WITH_X11XVMC)
+USE_XORG+= xvmc
+CONFIGURE_ARGS+=--enable-xvmc --with-xvmclib=XvMCW
+.endif
.else #WITHOUT_X11
CONFIGURE_ARGS+=--disable-x11 \
--disable-fontconfig