aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2010-09-03 03:56:12 +0800
committerrene <rene@FreeBSD.org>2010-09-03 03:56:12 +0800
commit963e83ba0ed29ed5bd3645d1dbf7b5aed25ef2c8 (patch)
tree520e08a5c1ea9963a7fd10bb7dc4dc0fbe1d09f0 /multimedia/mplayer
parent1fd80e3dadbb1f1bb115f3aaa2a852d31b851af1 (diff)
downloadfreebsd-ports-gnome-963e83ba0ed29ed5bd3645d1dbf7b5aed25ef2c8.tar.gz
freebsd-ports-gnome-963e83ba0ed29ed5bd3645d1dbf7b5aed25ef2c8.tar.zst
freebsd-ports-gnome-963e83ba0ed29ed5bd3645d1dbf7b5aed25ef2c8.zip
- correctly pick up dependency on libvpx if selected in options
- remove mencoder dependency on mplayer, the two ports can now be installed independently. - remove dependency on liba52 as this is handled by internal libavcodec - correctly handle dependency on external libschroedinger PR: ports/149534 Submitted by: maintainer Tested by: Christopher Key [cjk32 cam.ac.uk]
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile3
-rw-r--r--multimedia/mplayer/Makefile.options8
-rw-r--r--multimedia/mplayer/Makefile.shared3
3 files changed, 11 insertions, 3 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 4439d2e45db2..677c5ab83e0b 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
.include "${.CURDIR}/Makefile.shared"
@@ -47,6 +47,7 @@ OPTIONS+= LIBMPCDEC "Enable libmpcdec support" off
OPTIONS+= LADSPA "Enable LADSPA plugin support" off
OPTIONS+= SPEEX "Enable speex audio codec support" on
OPTIONS+= THEORA "Enable ogg theora video support" off
+OPTIONS+= VPX "Enable VP8 video via libvpx" off
OPTIONS+= SCHROEDINGER "Dirac codec via libschroedinger" off
.if !defined(PACKAGE_BUILDING)
OPTIONS+= WIN32 "Enable win32 codec set on the IA32 arch" on
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 666b96017b06..c47aa0aacb16 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -84,10 +84,16 @@ LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
CONFIGURE_ARGS+= --disable-theora
.endif
+.if defined(WITH_VPX)
+LIB_DEPENDS+= vpx.0:${PORTSDIR}/multimedia/libvpx
+.else
+CONFIGURE_ARGS+= --disable-libvpx-lavc
+.endif
+
.if defined(WITH_SCHROEDINGER)
LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
.else
-CONFIGURE_ARGS+= --disable-libschroedinger
+CONFIGURE_ARGS+= --disable-libschroedinger-lavc
.endif
.if defined(WITH_LIBMPCDEC)
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 2b318b2d30b0..f1778461b73d 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -24,7 +24,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
TMPDIR="${WRKSRC}"
-CONFIGURE_ARGS= --disable-bitmap-font
+CONFIGURE_ARGS= --disable-bitmap-font \
+ --disable-liba52
WANT_GNOME= yes
WANT_SDL= yes