aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-08-26 15:52:37 +0800
committervs <vs@FreeBSD.org>2004-08-26 15:52:37 +0800
commitdef06c1cef879459ad534d16136da191e1f56809 (patch)
tree09ff8d9fa7bdc70176aedd6a907039901b0c7356 /multimedia/mplayer
parent06990396b7d27f3f573b58de292a9fc1df84db9d (diff)
downloadfreebsd-ports-gnome-def06c1cef879459ad534d16136da191e1f56809.tar.gz
freebsd-ports-gnome-def06c1cef879459ad534d16136da191e1f56809.tar.zst
freebsd-ports-gnome-def06c1cef879459ad534d16136da191e1f56809.zip
Requested by Koop Mast:
- Correct detection of ogg theora codec - Avoid accidently linking to libtremor if not explicitly forced by user (important, therefore PORTREVISION bump!) PR: ports/70959 Submitted by: Thomas E. Zander (maintainer)
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 1d911d1eac49..8acf09221411 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -158,6 +158,14 @@
# WITH_AALIB
# default: autodetect
#
+# WITH_THEORA
+# default: autodetect
+#
+# WITH_TREMOR
+# default: autodetect
+# By setting this option mplayer will use libtremor (integer only vorbis
+# decoding lib) instead of libvorbis even if libvorbis is installed.
+#
# WITH_SDL
# default: autodetect
# (implies WITH_AALIB)
@@ -219,7 +227,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -321,6 +329,10 @@ WITH_MAD= yes
WITH_SVGALIB= yes
.endif
+.if exists(${LOCALBASE}/lib/libtheora.so.0)
+WITH_THEORA= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libaa.so.1)
WITH_AALIB= yes
.endif
@@ -503,6 +515,17 @@ LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
.endif
+.if defined(WITH_THEORA)
+LIB_DEPENDS+= theora.0:${PORTSDIR}/graphics/libtheora
+.endif
+
+.if defined(WITH_TREMOR)
+LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
+CONFIGURE_ARGS+= --enable-tremor
+.else
+CONFIGURE_ARGS+= --disable-tremor
+.endif
+
.if defined(WITH_SDL)
USE_SDL= sdl
.endif