aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mplayerxp
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /multimedia/mplayerxp
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'multimedia/mplayerxp')
-rw-r--r--multimedia/mplayerxp/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 84a83d707acb..82ecb31f51b4 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -29,10 +29,10 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
HAS_CONFIGURE= yes
+WANT_SDL= yes
MAN1= mplayerxp.1
-SDL_CONFIG?= "${LOCALBASE}/bin/sdl11-config"
WIN32_CODEC_PREFIX= ${LOCALBASE}/lib/win32
# dirs to create before installation
@@ -80,11 +80,11 @@ WITH_CDPARANOIA=yes
WITH_DVD=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL=yes
.endif
# sdl_image
-.if exists(${LOCALBASE}/lib/libSDL_image.a)
+.if ${HAVE_SDL:Mimage}!=""
WITH_SDL_IMAGE=yes
.endif
# xvid
@@ -139,17 +139,14 @@ CONFIGURE_ARGS+= --with-libdvdnav=${LOCALBASE}
.endif
# sdl
.ifdef(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --enable-sdl
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
.else
CONFIGURE_ARGS+= --disable-sdl
.endif
# sdl_image
.ifdef(WITH_SDL_IMAGE)
-LIB_DEPENDS+= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL+= image
CONFIGURE_ARGS+= --enable-sdl-image
.else
CONFIGURE_ARGS+= --disable-sdl-image