aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mtv
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /multimedia/mtv
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'multimedia/mtv')
-rw-r--r--multimedia/mtv/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/multimedia/mtv/Makefile b/multimedia/mtv/Makefile
index c96b9adf8db3..7780417400ce 100644
--- a/multimedia/mtv/Makefile
+++ b/multimedia/mtv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mtv
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia linux
MASTER_SITES= ftp://ftp.mpegtv.com/pub/mpeg/mpegtv/player/x86-unknown-linux-glibc/packages/TGZ/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz libSDLx11.so.tar.gz
@@ -15,18 +15,19 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz libSDLx11.so.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= High-performance MPEG video player (shareware)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
NO_PACKAGE= "No redistribution"
NO_CDROM= "No redistribution"
-NO_BUILD= yes
-NO_FILTER_SHLIBS=yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mtv
MAN1= mtv.1
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/mtv ${WRKSRC}/mtvp
+
do-install:
@${MKDIR} ${WRKDIR}/libSDLx11
@${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/libSDLx11.so.tar.gz \
@@ -34,8 +35,8 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/libSDLx11/libSDLx11.so.0.9.9 \
${LINUXBASE}/usr/X11R6/lib
${LINUXBASE}/sbin/ldconfig
- ${INSTALL_SCRIPT} ${WRKSRC}/mtv ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/mtvp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mtv ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mtvp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mtv.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/mtv