aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/nmm
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2008-04-25 23:54:17 +0800
committernetchild <netchild@FreeBSD.org>2008-04-25 23:54:17 +0800
commitde193f93ed8cd9e60ff36330517f7548360a3c84 (patch)
tree39be666a27de568a0159e988018949db6679d1f9 /multimedia/nmm
parent0022aaf58661d515f5623aa01309d920c9166acc (diff)
downloadfreebsd-ports-gnome-de193f93ed8cd9e60ff36330517f7548360a3c84.tar.gz
freebsd-ports-gnome-de193f93ed8cd9e60ff36330517f7548360a3c84.tar.zst
freebsd-ports-gnome-de193f93ed8cd9e60ff36330517f7548360a3c84.zip
- Patch: TCP_CORK (Linux) is similar to TCP_NOPUSH (since FreeBSD 4.5)
- TODO removal: OSS audio support is available already
Diffstat (limited to 'multimedia/nmm')
-rw-r--r--multimedia/nmm/Makefile3
-rw-r--r--multimedia/nmm/files/patch-nmm_utils_net_SockStream_Linux_cpp35
2 files changed, 25 insertions, 13 deletions
diff --git a/multimedia/nmm/Makefile b/multimedia/nmm/Makefile
index 6508fb6132ab..11324d644107 100644
--- a/multimedia/nmm/Makefile
+++ b/multimedia/nmm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nmm
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.motama.com/download/
@@ -78,8 +79,6 @@ post-install:
#
## TODO
#
-# - OSS audio support
-# to be written from scratch
# - libraw1394 (SF)
# for firewire support
# - libliveMedia (live555.com)
diff --git a/multimedia/nmm/files/patch-nmm_utils_net_SockStream_Linux_cpp b/multimedia/nmm/files/patch-nmm_utils_net_SockStream_Linux_cpp
index 0d2e24dde38c..53f14ce0a7ad 100644
--- a/multimedia/nmm/files/patch-nmm_utils_net_SockStream_Linux_cpp
+++ b/multimedia/nmm/files/patch-nmm_utils_net_SockStream_Linux_cpp
@@ -1,20 +1,33 @@
---- nmm/utils/net/SockStream_Linux.cpp.orig 2008-04-18 16:00:06.574327511 +0200
-+++ nmm/utils/net/SockStream_Linux.cpp 2008-04-18 16:02:21.213756868 +0200
-@@ -268,7 +268,7 @@
+--- nmm/utils/net/SockStream_Linux.cpp.orig 2007-08-13 23:43:07.000000000 +0200
++++ nmm/utils/net/SockStream_Linux.cpp 2008-04-25 16:53:19.270356178 +0200
+@@ -266,6 +266,14 @@
+ return size;
+ }
++#if defined(__FreeBSD__)
++// FreeBSD since 4.5 has the same semantics.
++// As 4.5 is a very old release and not supported by FreeBSD anymore, there's
++// no special check, we just assume the way too old releases are not used
++// with NMM.
++#define TCP_CORK TCP_NOPUSH
++#endif
++
#ifndef __CYGWIN__
void SockStream::enablePartialFrames(const bool& value){
--#ifndef BUILD_MACOSX
-+#if !defined(BUILD_MACOSX) && !defined(__FreeBSD__)
- if ( setsockopt(getSocket(), SOL_TCP, TCP_CORK, reinterpret_cast<const char*>(&value), sizeof(value)) == -1) {
- createSetSockOptException(errno);
- }
-@@ -283,7 +283,7 @@
+ #ifndef BUILD_MACOSX
+@@ -282,14 +290,12 @@
+
bool SockStream::isPartialFramesEnabled(){
int retval = 0;
- #ifndef __CYGWIN__
+-#ifndef __CYGWIN__
-#ifndef BUILD_MACOSX
-+#if !defined(BUILD_MACOSX) && !defined(__FreeBSD__)
++#if !defined(BUILD_MACOSX) && !defined(__CYGWIN__)
unsigned int size = sizeof(retval);
if (getsockopt(getSocket(), SOL_TCP, TCP_CORK, reinterpret_cast<char*>(&retval), &size) == -1) {
createSetSockOptException(errno);
+ }
+ #endif
+-#endif
+ return retval;
+ }
+