aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ogle-gui/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-01-11 01:00:30 +0800
committerlioux <lioux@FreeBSD.org>2002-01-11 01:00:30 +0800
commit15e51744f73faaad991295a8a5e5ba2f47539f54 (patch)
treedbd056b15b88262b3fc71321be342234c536a365 /multimedia/ogle-gui/Makefile
parent827789d736822637961996e931e0eb0358631a5b (diff)
downloadfreebsd-ports-gnome-15e51744f73faaad991295a8a5e5ba2f47539f54.tar.gz
freebsd-ports-gnome-15e51744f73faaad991295a8a5e5ba2f47539f54.tar.zst
freebsd-ports-gnome-15e51744f73faaad991295a8a5e5ba2f47539f54.zip
o Deal correctly with gnome: use proper paths if it is not
installed but benefit from it otherwise o Fix PLIST due to aforementioned o Bump PORTREVISION Submitted by: HIYAMA Takeshi <cbc06942@pop06.odn.ne.jp> Prompted by: jedgar, Øyvind Kolbu <oyvind@kebab.gaffel.nu>
Diffstat (limited to 'multimedia/ogle-gui/Makefile')
-rw-r--r--multimedia/ogle-gui/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/multimedia/ogle-gui/Makefile b/multimedia/ogle-gui/Makefile
index d0ea715a6532..1afa59c7347b 100644
--- a/multimedia/ogle-gui/Makefile
+++ b/multimedia/ogle-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ogle
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
PKGNAMESUFFIX= -gui
@@ -24,6 +25,7 @@ RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
USE_X_PREFIX= yes
USE_GTK= yes
USE_XPM= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
@@ -35,16 +37,27 @@ CONFIGURE_ARGS= --with-dvd-includes=${LOCALBASE}/include \
--with-libglade-config=${X11BASE}/bin/libglade-config \
--with-xml-prefix=${LOCALBASE}
+.include <bsd.port.pre.mk>
+
+.ifdef(HAVE_GNOME)
+USE_GNOME= yes
+SHARE_DATADIR= share/gnome
+.else
+SHARE_DATADIR= share
+.endif
+
+PLIST_SUB= SHARE_DATADIR="${SHARE_DATADIR}"
+
post-patch:
@${PERL} -pi -e "s|(libglade\.so)\.0|\1.4|; \
- s|(PACKAGE_PIXMAPS_DIR=\"$${prefix}/share/)(ogle_gui/\")|\1gnome/\2|; \
+ s|(PACKAGE_PIXMAPS_DIR=\"$${prefix}/)share(/ogle_gui/\")|\1${SHARE_DATADIR}\2|; \
s!(CONFIG_FILE(\s|=)\")[^/]+?/!\1${LOCALBASE}/!; \
s|(CONFIG_FILE_DTD=\")[^/]+?/|\1${LOCALBASE}/|g; \
- s|(PACKAGE_PIXMAPS_DIR=\").+\"|\1${PREFIX}/share/gnome/ogle_gui/\"|; \
+ s|(PACKAGE_PIXMAPS_DIR=\").+\"|\1${PREFIX}/${SHARE_DATADIR}/ogle_gui/\"|; \
s|%%LOCALBASE%%|${LOCALBASE}|" \
${CONFIGURE_WRKSRC}/configure
post-configure:
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>