aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ogmrip/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-11-20 02:23:48 +0800
committerhq <hq@FreeBSD.org>2004-11-20 02:23:48 +0800
commite68c602632f8a1e84edc4abf813ca9c60373457c (patch)
tree5aa5db7691367f709eac211fefd242487e1b2f46 /multimedia/ogmrip/Makefile
parentcde9c2adb17aa4784d7fdd78ffb16c02942156e8 (diff)
downloadfreebsd-ports-gnome-e68c602632f8a1e84edc4abf813ca9c60373457c.tar.gz
freebsd-ports-gnome-e68c602632f8a1e84edc4abf813ca9c60373457c.tar.zst
freebsd-ports-gnome-e68c602632f8a1e84edc4abf813ca9c60373457c.zip
OGMRip is an application and a set of libraries for ripping and encoding DVD
into DivX/OGM files using a wide variety of codecs. It relies on mplayer, mencoder, ogmtools, oggenc and lame to perform its tasks. The GUI features a clean high-compliant GNOME 2 interface and tries to minimize as much as possible esoteric settings. WWW: http://ogmrip.sourceforge.net/
Diffstat (limited to 'multimedia/ogmrip/Makefile')
-rw-r--r--multimedia/ogmrip/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
new file mode 100644
index 000000000000..aa3f2ddb9ab4
--- /dev/null
+++ b/multimedia/ogmrip/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: ogmrip
+# Date created: 2004-11-19
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ogmrip
+PORTVERSION= 0.5.1
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Application and libraries for encoding DVDs into DivX/OGM files
+
+BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ ogmmerge:${PORTSDIR}/multimedia/ogmtools \
+ lame:${PORTSDIR}/audio/lame
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= xvidcore:${PORTSDIR}/multimedia/xvid \
+ dvdread:${PORTSDIR}/multimedia/libdvdread
+
+USE_REINPLACE= yes
+USE_GNOME= gtk20 glib20 libgnomeui gconf2 libgnome libglade2
+USE_LIBTOOL_VER=15
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --sharedstatedir=${PREFIX}/libdata
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/data/Makefile.in
+
+pre-configure:
+ @if ${LOCALBASE}/mencoder -ovc help 2> /dev/null | ${GREP} -q "^ *xvid *- .*" ; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "This port requires a version of MEncoder compiled with XviD support." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+
+.include <bsd.port.post.mk>