aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/p5-Video-Info/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-02-25 09:51:02 +0800
committerijliao <ijliao@FreeBSD.org>2004-02-25 09:51:02 +0800
commit55fcc4330282b243c9b8967d656e4c0081205366 (patch)
tree2690202e1e670bc3989893fb05a930f5cd00be6d /multimedia/p5-Video-Info/Makefile
parentf7d33663ebb337c61203deab38b55587e95211ba (diff)
downloadfreebsd-ports-gnome-55fcc4330282b243c9b8967d656e4c0081205366.tar.gz
freebsd-ports-gnome-55fcc4330282b243c9b8967d656e4c0081205366.tar.zst
freebsd-ports-gnome-55fcc4330282b243c9b8967d656e4c0081205366.zip
add p5-Video-Info 0.993
Retrieve video properties such as: height width codec fps
Diffstat (limited to 'multimedia/p5-Video-Info/Makefile')
-rw-r--r--multimedia/p5-Video-Info/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/multimedia/p5-Video-Info/Makefile b/multimedia/p5-Video-Info/Makefile
new file mode 100644
index 000000000000..9ded2d8ff9f6
--- /dev/null
+++ b/multimedia/p5-Video-Info/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Video-Info
+# Date Created: Feb 25, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Video-Info
+PORTVERSION= 0.993
+CATEGORIES= multimedia perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Video
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Retrieve video properties such as: height width codec fps
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/MakeMethods/Emulator.pm:${PORTSDIR}/devel/p5-Class-MakeMethods \
+ ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/${PERL_ARCH}/Video/OpenQuicktime.pm:${PORTSDIR}/multimedia/p5-Video-OpenQuicktime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Video::Info.3 \
+ Video::Info::ASF.3 \
+ Video::Info::FOO.3 \
+ Video::Info::MPEG.3 \
+ Video::Info::MPEG::Audio.3 \
+ Video::Info::MPEG::Constants.3 \
+ Video::Info::MPEG::System.3 \
+ Video::Info::MPEG::Video.3 \
+ Video::Info::Magic.3 \
+ Video::Info::Quicktime.3 \
+ Video::Info::RIFF.3
+
+.include <bsd.port.mk>