aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/pitivi/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-07-19 20:41:38 +0800
committerkwm <kwm@FreeBSD.org>2005-07-19 20:41:38 +0800
commitda087a9120f37056f76a7da166ed65543114befb (patch)
tree224166b0f86e83ef1eceb0fc80846c36a92ff33d /multimedia/pitivi/Makefile
parenta95e273b75e2a8119bf14975e791ab7a0571521a (diff)
downloadfreebsd-ports-gnome-da087a9120f37056f76a7da166ed65543114befb.tar.gz
freebsd-ports-gnome-da087a9120f37056f76a7da166ed65543114befb.tar.zst
freebsd-ports-gnome-da087a9120f37056f76a7da166ed65543114befb.zip
Update to 0.1.10.
Diffstat (limited to 'multimedia/pitivi/Makefile')
-rw-r--r--multimedia/pitivi/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/multimedia/pitivi/Makefile b/multimedia/pitivi/Makefile
index 69aa6bed915a..40c63281febb 100644
--- a/multimedia/pitivi/Makefile
+++ b/multimedia/pitivi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pitivi
-PORTVERSION= 0.1.1
-PORTREVISION= 3
+PORTVERSION= 0.1.10
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,13 +14,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Gstreamer based non-linear audio/video editor
-CONFLICTS= gnonlin-0.*
+BUILD_DEPENDS= gnonlin-config:${PORTSDIR}/multimedia/gnonlin \
+ ${PYTHON_SITELIBDIR}/gst/_gst.so:${PORTSDIR}/multimedia/py-gstreamer
+RUN_DEPENDS= gnonlin-config:${PORTSDIR}/multimedia/gnonlin \
+ ${PYTHON_SITELIBDIR}/gst/_gst.so:${PORTSDIR}/multimedia/py-gstreamer
-USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnometarget gnomeprefix
-USE_GSTREAMER= gconf
+USE_GNOME= gnometarget gnomeprefix pygtk2 pkgconfig pygnome2
+USE_GSTREAMER= yes
USE_LIBTOOL_VER=15
USE_PYTHON= yes
GNU_CONFIGURE= yes
@@ -29,8 +31,9 @@ CONFIGURE_ARGS= --disable-docs-build
INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' \
- ${WRKSRC}/gnl/Makefile.in \
- ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${LOCALBASE}/bin/python|g' \
+ ${WRKSRC}/bin/pitivi.in
+ @${REINPLACE_CMD} -e 's|0.1.9|0.1.10|g' \
+ ${WRKSRC}/pitivi/ui/mainwindow.py
.include <bsd.port.mk>