aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/plexhometheater
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-04-17 02:03:17 +0800
committerriggs <riggs@FreeBSD.org>2016-04-17 02:03:17 +0800
commit4873e4ff086484cfdbf93e8e843db2e2b2a2ca3e (patch)
tree18ed17e8b692ab5cb938e073ce6506934065836f /multimedia/plexhometheater
parent34dbb352f15f582a4c3123ae56bc6c9c53896463 (diff)
downloadfreebsd-ports-gnome-4873e4ff086484cfdbf93e8e843db2e2b2a2ca3e.tar.gz
freebsd-ports-gnome-4873e4ff086484cfdbf93e8e843db2e2b2a2ca3e.tar.zst
freebsd-ports-gnome-4873e4ff086484cfdbf93e8e843db2e2b2a2ca3e.zip
Fix build with recent libcec 3.1.0 update; bump PORTREVISION
PR: 208161 Submitted by: mickael.maillot@gmail.com Approved by: woodsb02@gmail.com (maintainer)
Diffstat (limited to 'multimedia/plexhometheater')
-rw-r--r--multimedia/plexhometheater/Makefile4
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_peripherals_devices_PeripheralCecAdapter.cpp38
2 files changed, 40 insertions, 2 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 34c7305285ce..ef3cae9732aa 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -3,7 +3,7 @@
PORTNAME= plexhometheater
PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX=v
DISTVERSIONSUFFIX=.469-47a90f01
CATEGORIES= multimedia
@@ -103,7 +103,7 @@ CEC_DESC= Control plexhometheater over HDMI with TV remote
OPTIONS_DEFAULT= CEC LIRC
-CEC_BUILD_DEPENDS= libcec>=2.2.0:multimedia/libcec
+CEC_BUILD_DEPENDS= libcec>=3.0.0:multimedia/libcec
CEC_LIB_DEPENDS= libcec.so:multimedia/libcec
CEC_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_CEC:BOOL=true
diff --git a/multimedia/plexhometheater/files/patch-xbmc_peripherals_devices_PeripheralCecAdapter.cpp b/multimedia/plexhometheater/files/patch-xbmc_peripherals_devices_PeripheralCecAdapter.cpp
new file mode 100644
index 000000000000..fa67459b4306
--- /dev/null
+++ b/multimedia/plexhometheater/files/patch-xbmc_peripherals_devices_PeripheralCecAdapter.cpp
@@ -0,0 +1,38 @@
+--- xbmc/peripherals/devices/PeripheralCecAdapter.cpp.orig 2015-05-11 09:54:22 UTC
++++ xbmc/peripherals/devices/PeripheralCecAdapter.cpp
+@@ -44,7 +44,7 @@ using namespace ANNOUNCEMENT;
+ using namespace CEC;
+ using namespace std;
+
+-#define CEC_LIB_SUPPORTED_VERSION 0x2100
++#define CEC_LIB_SUPPORTED_VERSION LIBCEC_VERSION_TO_UINT(3, 0, 0)
+
+ /* time in seconds to ignore standby commands from devices after the screensaver has been activated */
+ #define SCREENSAVER_TIMEOUT 10
+@@ -282,7 +282,7 @@ bool CPeripheralCecAdapter::InitialiseFe
+ }
+ else
+ {
+- CLog::Log(LOGDEBUG, "%s - using libCEC v%s", __FUNCTION__, m_cecAdapter->ToString((cec_server_version)m_configuration.serverVersion));
++ CLog::Log(LOGDEBUG, "%s - using libCEC v%s", __FUNCTION__, m_cecAdapter->VersionToString(m_configuration.serverVersion).c_str());
+ SetVersionInfo(m_configuration);
+ }
+
+@@ -295,7 +295,7 @@ bool CPeripheralCecAdapter::InitialiseFe
+
+ void CPeripheralCecAdapter::SetVersionInfo(const libcec_configuration &configuration)
+ {
+- m_strVersionInfo.Format("libCEC %s - firmware v%d", m_cecAdapter->ToString((cec_server_version)configuration.serverVersion), configuration.iFirmwareVersion);
++ m_strVersionInfo.Format("libCEC %s - firmware v%d", m_cecAdapter->VersionToString(configuration.serverVersion).c_str(), configuration.iFirmwareVersion);
+
+ // append firmware build date
+ if (configuration.iFirmwareBuildDate != CEC_FW_BUILD_UNKNOWN)
+@@ -1303,7 +1303,7 @@ void CPeripheralCecAdapter::SetConfigura
+ void CPeripheralCecAdapter::SetConfigurationFromSettings(void)
+ {
+ // client version matches the version of libCEC that we originally used the API from
+- m_configuration.clientVersion = CEC_CLIENT_VERSION_2_2_0;
++ m_configuration.clientVersion = LIBCEC_VERSION_TO_UINT(3, 0, 0);
+
+ // device name 'XBMC'
+ snprintf(m_configuration.strDeviceName, 13, "%s", GetSettingString("device_name").c_str());