aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/py-gstreamer
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-11-21 02:17:25 +0800
committerkwm <kwm@FreeBSD.org>2004-11-21 02:17:25 +0800
commitdb6dc6d2da8576580dcb124ef521c8a3efa2f725 (patch)
treec314ab145631ecbd015bd882cfccc29d43af7876 /multimedia/py-gstreamer
parent570d2baa1cb74eac573326675145c94eb5181c83 (diff)
downloadfreebsd-ports-gnome-db6dc6d2da8576580dcb124ef521c8a3efa2f725.tar.gz
freebsd-ports-gnome-db6dc6d2da8576580dcb124ef521c8a3efa2f725.tar.zst
freebsd-ports-gnome-db6dc6d2da8576580dcb124ef521c8a3efa2f725.zip
Update to version 0.8.0.
Use my FreeBSD address in the maintainer field. Approved by: pav (mentor)
Diffstat (limited to 'multimedia/py-gstreamer')
-rw-r--r--multimedia/py-gstreamer/Makefile29
-rw-r--r--multimedia/py-gstreamer/distinfo4
-rw-r--r--multimedia/py-gstreamer/pkg-plist21
3 files changed, 27 insertions, 27 deletions
diff --git a/multimedia/py-gstreamer/Makefile b/multimedia/py-gstreamer/Makefile
index 322ef952b738..9eb69cc9708f 100644
--- a/multimedia/py-gstreamer/Makefile
+++ b/multimedia/py-gstreamer/Makefile
@@ -6,18 +6,22 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.7.92
-PORTREVISION= 3
+PORTVERSION= 0.8.0
CATEGORIES= multimedia python gnome
-MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-python/
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-python/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kwm
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= gst-python-${PORTVERSION}
-MAINTAINER= kwm@rainbow-runner.nl
+MAINTAINER= kwm@FreeBSD.org
COMMENT= A set of Python bindings for gstreamer
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
+
.if !defined(NOPORTDOCS)
-BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
+BUILD_DEPENDS+= xmlto:${PORTSDIR}/textproc/xmlto \
lynx:${PORTSDIR}/www/lynx
.endif
@@ -26,15 +30,12 @@ USE_GMAKE= yes
USE_GNOME= gstreamerplugins \
pygtk2 \
gnomehack \
- pkgconfig \
- lthack
-USE_LIBTOOL_VER=13
+ pkgconfig
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}"
DOCS= README.html README.txt
-EXAMPLES= gst/bps.py gst/cp.py gst/dvdplay.py gst/f2f.py \
- gst/identity.py gst/ilat.py gst/lat.py gst/rot13.py \
- gst/vorbisplay.py gst/wavenc.py gstplay/player.py
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS= --enable-docs
@@ -42,13 +43,13 @@ CONFIGURE_ARGS= --enable-docs
CONFIGURE_ARGS= --disable-docs
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|DLFCN|dl|g' ${WRKSRC}/gst/__init__.py
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/docs && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.for i in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/examples/${i} ${DOCSDIR}/
-.endfor
.endif
.include <bsd.port.mk>
diff --git a/multimedia/py-gstreamer/distinfo b/multimedia/py-gstreamer/distinfo
index 61e7743687f1..4a16297f96bc 100644
--- a/multimedia/py-gstreamer/distinfo
+++ b/multimedia/py-gstreamer/distinfo
@@ -1,2 +1,2 @@
-MD5 (gst-python-0.7.92.tar.gz) = c4bcec0671d3a67e73d3d77b51bd5296
-SIZE (gst-python-0.7.92.tar.gz) = 403049
+MD5 (gst-python-0.8.0.tar.gz) = d8705548cac1ef8492c87617383b8380
+SIZE (gst-python-0.8.0.tar.gz) = 389310
diff --git a/multimedia/py-gstreamer/pkg-plist b/multimedia/py-gstreamer/pkg-plist
index b03b3bd45d97..217a496386c4 100644
--- a/multimedia/py-gstreamer/pkg-plist
+++ b/multimedia/py-gstreamer/pkg-plist
@@ -7,18 +7,17 @@
libdata/pkgconfig/gst-python-0.8.pc
%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/bps.py
-%%PORTDOCS%%%%DOCSDIR%%/cp.py
-%%PORTDOCS%%%%DOCSDIR%%/dvdplay.py
-%%PORTDOCS%%%%DOCSDIR%%/f2f.py
-%%PORTDOCS%%%%DOCSDIR%%/identity.py
-%%PORTDOCS%%%%DOCSDIR%%/ilat.py
-%%PORTDOCS%%%%DOCSDIR%%/lat.py
-%%PORTDOCS%%%%DOCSDIR%%/player.py
-%%PORTDOCS%%%%DOCSDIR%%/rot13.py
-%%PORTDOCS%%%%DOCSDIR%%/vorbisplay.py
-%%PORTDOCS%%%%DOCSDIR%%/wavenc.py
share/gst-python/2.0/defs/gst-types.defs
+share/gst-python/examples/bps.py
+share/gst-python/examples/cp.py
+share/gst-python/examples/f2f.py
+share/gst-python/examples/filesrc.py
+share/gst-python/examples/gst123
+share/gst-python/examples/play.py
+share/gst-python/examples/player.py
+share/gst-python/examples/videoplayer.py
+share/gst-python/examples/vorbisplay.py
+@dirrm share/gst-python/examples
@dirrm share/gst-python/2.0/defs
@dirrm share/gst-python/2.0
@dirrm share/gst-python