aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/qt4-phonon
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
committermakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
commit1b9ec1582fbf2b219f611d52fca8410e3cd06973 (patch)
tree42a169743be676e050a1e903ddf771488b5da9bb /multimedia/qt4-phonon
parent69e87da3a0f46ad0c31d376913c821cc72c51ecd (diff)
downloadfreebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.gz
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.zst
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.zip
KDE FreeBSD team is glad to present Qt 4.7.1 in ports.
Along with Qt4 the following ports are updated: PyQt4 ports to 4.8.1 devel/py-sip to 4.11.2 devel/qscintilla2 to 2.4.5 PyKDE3 to 3.16.7 PyQt3 tp 3.18.2-snapshot-20091119 New ports added: devel/qt4-declarative devel/py-qt4-declarative x11/qt4-graphicssystems-opengl This release has been contributed by: Thomas Abthorpe (tabthorpe) Max Brazhnikov (makc) Dima Panov (fluffy) Alberto Villa (avilla) We'd like to thank Martin Wilke (miwi) for exp-run.
Diffstat (limited to 'multimedia/qt4-phonon')
-rw-r--r--multimedia/qt4-phonon/Makefile4
-rw-r--r--multimedia/qt4-phonon/pkg-plist16
2 files changed, 15 insertions, 5 deletions
diff --git a/multimedia/qt4-phonon/Makefile b/multimedia/qt4-phonon/Makefile
index 8e69b295e86d..2de759ecbc45 100644
--- a/multimedia/qt4-phonon/Makefile
+++ b/multimedia/qt4-phonon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phonon
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
@@ -49,7 +49,7 @@ EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
.include <bsd.port.pre.mk>
.if !defined(WITH_QT_PHONON)
-IGNORE= conflicts with multimedia/phonon. You have defined WITH_KDE_PHONON to override Qt4 phonon
+IGNORE= conflicts with multimedia/phonon. Define WITH_QT_PHONON to install Qt 4 phonon
.endif
pre-configure:
diff --git a/multimedia/qt4-phonon/pkg-plist b/multimedia/qt4-phonon/pkg-plist
index d306ac2b6f93..28f2db26d1e3 100644
--- a/multimedia/qt4-phonon/pkg-plist
+++ b/multimedia/qt4-phonon/pkg-plist
@@ -7,6 +7,8 @@ include/qt4/phonon/AudioCaptureDevice
include/qt4/phonon/AudioCaptureDeviceModel
include/qt4/phonon/AudioChannelDescription
include/qt4/phonon/AudioChannelDescriptionModel
+include/qt4/phonon/AudioDataOutput
+include/qt4/phonon/AudioDataOutputInterface
include/qt4/phonon/AudioOutput
include/qt4/phonon/AudioOutputDevice
include/qt4/phonon/AudioOutputDeviceModel
@@ -22,6 +24,7 @@ include/qt4/phonon/EffectInterface
include/qt4/phonon/EffectParameter
include/qt4/phonon/EffectWidget
include/qt4/phonon/Global
+include/qt4/phonon/GlobalConfig
include/qt4/phonon/MediaController
include/qt4/phonon/MediaNode
include/qt4/phonon/MediaObject
@@ -34,6 +37,7 @@ include/qt4/phonon/ObjectDescriptionModelData
include/qt4/phonon/Path
include/qt4/phonon/Phonon
include/qt4/phonon/PlatformPlugin
+include/qt4/phonon/PulseSupport
include/qt4/phonon/SeekSlider
include/qt4/phonon/StreamInterface
include/qt4/phonon/SubtitleDescription
@@ -41,6 +45,8 @@ include/qt4/phonon/SubtitleDescriptionModel
include/qt4/phonon/VideoPlayer
include/qt4/phonon/VideoWidget
include/qt4/phonon/VideoWidgetInterface
+include/qt4/phonon/VideoWidgetInterface44
+include/qt4/phonon/VideoWidgetInterfaceLatest
include/qt4/phonon/VolumeFaderEffect
include/qt4/phonon/VolumeFaderInterface
include/qt4/phonon/VolumeSlider
@@ -48,6 +54,8 @@ include/qt4/phonon/abstractaudiooutput.h
include/qt4/phonon/abstractmediastream.h
include/qt4/phonon/abstractvideooutput.h
include/qt4/phonon/addoninterface.h
+include/qt4/phonon/audiodataoutput.h
+include/qt4/phonon/audiodataoutputinterface.h
include/qt4/phonon/audiooutput.h
include/qt4/phonon/audiooutputinterface.h
include/qt4/phonon/backendcapabilities.h
@@ -56,6 +64,7 @@ include/qt4/phonon/effect.h
include/qt4/phonon/effectinterface.h
include/qt4/phonon/effectparameter.h
include/qt4/phonon/effectwidget.h
+include/qt4/phonon/globalconfig.h
include/qt4/phonon/mediacontroller.h
include/qt4/phonon/medianode.h
include/qt4/phonon/mediaobject.h
@@ -69,6 +78,7 @@ include/qt4/phonon/phonon_export.h
include/qt4/phonon/phonondefs.h
include/qt4/phonon/phononnamespace.h
include/qt4/phonon/platformplugin.h
+include/qt4/phonon/pulsesupport.h
include/qt4/phonon/seekslider.h
include/qt4/phonon/streaminterface.h
include/qt4/phonon/videoplayer.h
@@ -81,9 +91,9 @@ lib/qt4/libphonon.la
lib/qt4/libphonon.prl
lib/qt4/libphonon.so
lib/qt4/libphonon.so.4
-lib/qt4/libphonon.so.4.3
-lib/qt4/libphonon.so.4.3.1
-%%DEBUG%%lib/qt4/libphonon.so.4.3.1.debug
+lib/qt4/libphonon.so.4.4
+lib/qt4/libphonon.so.4.4.0
+%%DEBUG%%lib/qt4/libphonon.so.4.4.0.debug
libdata/pkgconfig/phonon.pc
@dirrmtry lib/qt4
@dirrm include/qt4/phonon