aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/subtitlecomposer-kde4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-11 04:31:30 +0800
committermakc <makc@FreeBSD.org>2013-10-11 04:31:30 +0800
commit28c4280d310b9fab7b906bfe1dcca5d6ba4cc4e0 (patch)
treeb6bfa9d67107824190b18441703c538801fd4d80 /multimedia/subtitlecomposer-kde4
parentbe1ece2e91803aed77de7ef0395413446f415e86 (diff)
downloadfreebsd-ports-gnome-28c4280d310b9fab7b906bfe1dcca5d6ba4cc4e0.tar.gz
freebsd-ports-gnome-28c4280d310b9fab7b906bfe1dcca5d6ba4cc4e0.tar.zst
freebsd-ports-gnome-28c4280d310b9fab7b906bfe1dcca5d6ba4cc4e0.zip
- Add explicit dependency on gettext and phonon
- Remove no longer needed patch - Use option helpers - Support staging
Diffstat (limited to 'multimedia/subtitlecomposer-kde4')
-rw-r--r--multimedia/subtitlecomposer-kde4/Makefile37
-rw-r--r--multimedia/subtitlecomposer-kde4/files/patch-src__core__subtitleline.cpp11
2 files changed, 13 insertions, 35 deletions
diff --git a/multimedia/subtitlecomposer-kde4/Makefile b/multimedia/subtitlecomposer-kde4/Makefile
index 641fbe933e25..c4ffa8780e99 100644
--- a/multimedia/subtitlecomposer-kde4/Makefile
+++ b/multimedia/subtitlecomposer-kde4/Makefile
@@ -10,34 +10,23 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Subtitle editor for KDE
USE_BZIP2= yes
-USES= cmake
+USES= cmake:outsource gettext
USE_KDE4= kdeprefix kdelibs automoc4 sharedmime
-USE_QT4= gui qmake_build moc_build rcc_build uic_build
+USE_QT4= qmake_build moc_build rcc_build uic_build phonon
-OPTIONS_DEFINE= GSTREAMER MPLAYER XINE
-OPTIONS_DEFAULT= MPLAYER
+OPTIONS_GROUP= BACKEND
+BACKEND_DESC= Additional video backens
+OPTIONS_GROUP_BACKEND= GSTREAMER MPLAYER XINE
-MPLAYER_DESC= Enable MPlayer backend (recommended)
-XINE_DESC= Enable Xine backend
-GSTREAMER_DESC= Enable GStreamer backend (broken)
+MPLAYER_DESC= Install MPlayer
+MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+XINE_DESC= Build Xine backend
+XINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
+XINE_CMAKE_OFF= -DWITH_Xine:Bool=Off
-.if ${PORT_OPTIONS:MMPLAYER}
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
-.endif
-
-.if ${PORT_OPTIONS:MXINE}
-LIB_DEPENDS+= libxine.so:${PORTSDIR}/multimedia/libxine
-.else
-CMAKE_ARGS+= -DWITH_Xine:Bool=Off
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-USE_GSTREAMER= yes
-.else
-CMAKE_ARGS+= -DWITH_GStreamer:Bool=Off
-.endif
+GSTREAMER_DESC= Build GStreamer backend (broken)
+GSTREAMER_USE= GSTREAMER=yes
+GSTREAMER_CMAKE_OFF= -DWITH_GStreamer:Bool=Off
.include <bsd.port.mk>
diff --git a/multimedia/subtitlecomposer-kde4/files/patch-src__core__subtitleline.cpp b/multimedia/subtitlecomposer-kde4/files/patch-src__core__subtitleline.cpp
deleted file mode 100644
index 8609e8364c54..000000000000
--- a/multimedia/subtitlecomposer-kde4/files/patch-src__core__subtitleline.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/core/subtitleline.cpp.orig 2008-01-08 09:16:27.000000000 +0300
-+++ ./src/core/subtitleline.cpp 2008-01-08 15:54:39.000000000 +0300
-@@ -41,7 +41,7 @@
- if ( flag < 1 )
- return ErrorUNKNOWN;
-
-- int id = (int)log2( flag );
-+ int id = int( log( flag ) * M_LN2 );
- return id < ErrorSIZE ? (ErrorID)id : ErrorUNKNOWN;
- }
-