aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/subtitlecomposer-kde4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
committermakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
commit7e9888a561c1f2a53cfeca5bf54f5278294df386 (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /multimedia/subtitlecomposer-kde4
parent7c887ca2a204b4cd88ce46806edb8ea718e69d9e (diff)
downloadfreebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.gz
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.zst
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.zip
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Diffstat (limited to 'multimedia/subtitlecomposer-kde4')
-rw-r--r--multimedia/subtitlecomposer-kde4/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/multimedia/subtitlecomposer-kde4/Makefile b/multimedia/subtitlecomposer-kde4/Makefile
index 492ffb9e0aa7..de515fad8524 100644
--- a/multimedia/subtitlecomposer-kde4/Makefile
+++ b/multimedia/subtitlecomposer-kde4/Makefile
@@ -18,30 +18,32 @@ USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= kdeprefix kdelibs automoc4
USE_QT4= gui qmake_build moc_build rcc_build uic_build
-WANT_GSTREAMER= yes
LATEST_LINK= ${PORTNAME}-kde4
-OPTIONS= MPLAYER "Enable MPlayer backend (recommended)" on \
- XINE "Enable Xine backend" off \
- GSTREAMER "Enable GStreamer backend (broken)" off
+OPTIONS_DEFINE= GSTREAMER MPLAYER XINE
+OPTIONS_DEFAULT= MPLAYER
-.include <bsd.port.pre.mk>
+MPLAYER_DESC= Enable MPlayer backend (recommended)
+XINE_DESC= Enable Xine backend
+GSTREAMER_DESC= Enable GStreamer backend (broken)
-.if defined(WITH_MPLAYER)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-.if defined(WITH_XINE)
+.if ${PORT_OPTIONS:MXINE}
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
.else
CMAKE_ARGS+= -DWITH_Xine:Bool=Off
.endif
-.if defined(WITH_GSTREAMER)
-USE_GSTREAMER+= yes
+.if ${PORT_OPTIONS:MGSTREAMER}
+USE_GSTREAMER= yes
.else
CMAKE_ARGS+= -DWITH_GStreamer:Bool=Off
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>