aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
committerkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
commitbe884cd42990f2e755c2c06bc38c8042cb8b0325 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /multimedia/totem/Makefile
parent1c38992aaca771dc7aab7ae768e5753c6381ecd3 (diff)
downloadfreebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.gz
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.zst
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Diffstat (limited to 'multimedia/totem/Makefile')
-rw-r--r--multimedia/totem/Makefile122
1 files changed, 53 insertions, 69 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index f8418df67da7..4fdf540f5f2c 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -1,78 +1,75 @@
# Created by: Hendrik Scholz <hendrik@scholz.net>
# $FreeBSD$
-# $MCom: ports/multimedia/totem/Makefile,v 1.151 2010/09/27 19:04:37 kwm Exp $
+# $MCom: ports/trunk/multimedia/totem/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= totem
-PORTVERSION= 2.32.0
-PORTREVISION?= 6
+PORTVERSION= 3.12.2
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
-MAINTAINER?= gnome@FreeBSD.org
-COMMENT?= Gstreamer-based video player for the GNOME 2 Desktop
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Gstreamer-based video player for the GNOME 3 Desktop
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
+ ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme \
+ appdata-tools>=0:${PORTSDIR}/devel/appdata-tools \
+ itstool:${PORTSDIR}/textproc/itstool \
+ grilo-plugins>=0:${PORTSDIR}/net/grilo-plugins
LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata \
- libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
+ libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3 \
+ libpeas-1.0.so:${PORTSDIR}/devel/libpeas \
libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
- ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon \
- ${PYTHON_SITELIBDIR}/atom/__init__.py:${PORTSDIR}/devel/py-gdata
-
-CONFLICTS= totem-3.[0-9]*
-
-GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
- pkgconfig python shebangfix tar:bzip2
-SHEBANG_FILES= data/totem-bugreport.py
-USE_GNOME= gnomehier gnomeprefix intlhack nautilus2 pygtk2
-USE_GSTREAMER= core gconf hal good mpeg2dec soup ugly python gio
+ ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme \
+ gnome-settings-daemon>=2.91.0:${PORTSDIR}/sysutils/gnome-settings-daemon \
+ gnome-icon-theme-symbolic>=2.91.0:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic \
+ grilo-plugins>=0:${PORTSDIR}/net/grilo-plugins
+
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ python:3 shebangfix tar:xz
+USE_GNOME= gnomeprefix gtk30 intlhack introspection:build \
+ libxml2 nautilus3 py3gobject3
+USE_XORG= x11 xproto xtst ice sm
+USE_GSTREAMER1= core good bad soup ugly
INSTALLS_ICONS= yes
-INSTALL_TARGET= install-strip
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-INSTALLS_OMF= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lXrandr
-CONFIGURE_ENV= BROWSER_PLUGIN_DIR="${WEBPLUGIN_DIR}"
+CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
+CFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LIBS="-lXrandr"
CONFIGURE_ARGS= --with-plugins="${TOTEM_PLUGINS}"
+SHEBANG_FILES= data/totem-bugreport.py
+CONFIGURE_ENV+= APPDATA_VALIDATE="${LOCALBASE}/bin/appdata-validate --nonet"
+MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
+INSTALL_TARGET= install-strip
-GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
- totem.schemas
+GLIB_SCHEMAS= org.gnome.totem.enums.xml \
+ org.gnome.totem.gschema.xml \
+ org.gnome.totem.plugins.opensubtitles.gschema.xml
-OPTIONS_DEFINE= LIRC GALAGO BROWSER_PLUGINS PUBLISH TRACKER
-GALAGO_DESC= Galago support
-BROWSER_PLUGINS_DESC= Plugins for gecko browser
-PUBLISH_DESC= Publish (network playlist) plugin
-TRACKER_DESC= Tracker local search plugin
+OPTIONS_DEFINE= LIRC BROWSER_PLUGINS
+BROWSER_PLUGINS_DESC= Web browser plugins
-OPTIONS_DEFAULT= BROWSER_PLUGINS
-# check configure script for allowed_plugins="..." for new plugins
-TOTEM_PLUGINS= thumbnail screensaver ontop gromit media-player-keys \
- properties skipto youtube opensubtitles screenshot \
- brasero-disc-recorder coherence_upnp dbus-service iplayer
+PLIST_SUB+= PYVER=${PYTHON_VER:S/.//}
-# Not using:
-# TOTEM_PLUGINS= mythtv bemused jamendo
+OPTIONS_DEFAULT=BROWSER_PLUGINS
-.include <bsd.port.options.mk>
+# check configure script for allowed_plugins="..." for new plugins
+TOTEM_PLUGINS= brasero-disc-recorder chapters dbusservice im-status grilo gromit \
+ iplayer media-player-keys ontop opensubtitles properties \
+ screensaver screenshot sidebar-test skipto youtube
-.if defined(WITH_PUBLISH)
-LIB_DEPENDS+= libepc-1.0.so:${PORTSDIR}/www/libepc
-PLIST_SUB+= PUBLISH=""
-TOTEM_PLUGINS:= ${TOTEM_PLUGINS} publish
-.else
-PLIST_SUB+= PUBLISH="@comment "
-.endif
+# pythonconsole samplepython
+# vala rotation sample-vala
+# nautilus save-file
+# iplayer zeitgeist-dp grilo
-#.if defined(WITH_TRACKER)
-#LIB_DEPENDS+= tracker-gtk.0:${PORTSDIR}/sysutils/tracker-libtrackergtk
-#TOTEM_PLUGINS:= ${TOTEM_PLUGINS} tracker
-#PLIST_SUB+= TRACKER=""
-#.else
-PLIST_SUB+= TRACKER="@comment "
-#.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIRC}
LIB_DEPENDS+= liblirc_client.so:${PORTSDIR}/comms/lirc
@@ -82,14 +79,6 @@ TOTEM_PLUGINS:= ${TOTEM_PLUGINS} lirc
PLIST_SUB+= LIRC="@comment "
.endif
-.if ${PORT_OPTIONS:MGALAGO}
-LIB_DEPENDS+= libgalago.so:${PORTSDIR}/devel/libgalago
-PLIST_SUB+= GALAGO=""
-TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
-.else
-PLIST_SUB+= GALAGO="@comment "
-.endif
-
.if ${PORT_OPTIONS:MBROWSER_PLUGINS}
CONFIGURE_ARGS+=--enable-browser-plugins \
--enable-gmp-plugin \
@@ -100,6 +89,8 @@ USES+= webplugin:native
WEBPLUGIN_FILES= libtotem-cone-plugin.so libtotem-gmp-plugin.so \
libtotem-mully-plugin.so \
libtotem-narrowspace-plugin.so
+CONFIGURE_ENV+= BROWSER_PLUGIN_DIR="${WEBPLUGIN_DIR}"
+
.else
CONFIGURE_ARGS+=--disable-browser-plugins \
--disable-basic-plugin \
@@ -111,7 +102,7 @@ PLIST_SUB+= BROWSER_PLUGINS="@comment "
.if defined(WITH_DVD_DEVICE)
DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
.else
-DEFAULT_DVD_DEVICE=/dev/acd0
+DEFAULT_DVD_DEVICE=/dev/cd0
.endif
pre-everything::
@@ -121,12 +112,5 @@ pre-everything::
post-patch:
@${CP} -f ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
- @${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
- ${WRKSRC}/src/backend/bacon-video-widget-gst-0.10.c
-
-post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/vala/vapi
- ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vapi ${STAGEDIR}${PREFIX}/share/vala/vapi
- ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.deps ${STAGEDIR}${PREFIX}/share/vala/vapi
.include <bsd.port.mk>