aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-04-30 07:03:03 +0800
committerahze <ahze@FreeBSD.org>2006-04-30 07:03:03 +0800
commit37141a4239ce132a460689dacc49f431214e670b (patch)
tree841e14a903993df6f2654c4de34024a326f9e59b /multimedia/totem/Makefile
parent8967d0ac35824f19b6b0545589662965de0f1988 (diff)
downloadfreebsd-ports-gnome-37141a4239ce132a460689dacc49f431214e670b.tar.gz
freebsd-ports-gnome-37141a4239ce132a460689dacc49f431214e670b.tar.zst
freebsd-ports-gnome-37141a4239ce132a460689dacc49f431214e670b.zip
- Update gstreamer to 0.10
- Move all old gstreamer 0.8 ports to gstreamer*80 [1] - Chase all ports with new gstreamer or gstreaemer moves Repocopied by: marcus [1]
Diffstat (limited to 'multimedia/totem/Makefile')
-rw-r--r--multimedia/totem/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 87bbe6b2ec7c..7f17eec05a82 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,24 +6,25 @@
#
PORTNAME= totem
-PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER?= hendrik@scholz.net
COMMENT?= A Xine-based video player for the Gnome 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-USE_REINPLACE= yes
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
nautiluscdburner
+GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -40,12 +41,10 @@ OPTIONS?= DVDNAV "Enable DVD support" on \
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS= totem-gstreamer-[0-9]*
+CONFLICTS?= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
-LIB_DEPENDS+= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
-
.if defined(WITH_MOZILLA_PLUGIN)
USE_GECKO= firefox mozilla seamonkey
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
@@ -58,9 +57,7 @@ CONFIGURE_ARGS+=--disable-mozilla
.endif
.if defined(WITH_GSTREAMER)
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-CONFIGURE_ARGS+=--enable-gstreamer
+CONFIGURE_ARGS+=--enable-gstreamer=0.10
USE_GSTREAMER+= gnomevfs core gconf
WITHOUT_DVDNAV= yes
PLIST_SUB+= GSTREAMER=""