aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-05-02 14:36:11 +0800
committermarcus <marcus@FreeBSD.org>2003-05-02 14:36:11 +0800
commit980f27d16fbb554d320fde66c5f3c2781781e7c8 (patch)
treedb89d7e39845b331d886be8e853ffdc860975e62 /multimedia/totem/Makefile
parent8f5ffa425dd1a9dc3d268da4ca3341681c66b66e (diff)
downloadfreebsd-ports-gnome-980f27d16fbb554d320fde66c5f3c2781781e7c8.tar.gz
freebsd-ports-gnome-980f27d16fbb554d320fde66c5f3c2781781e7c8.tar.zst
freebsd-ports-gnome-980f27d16fbb554d320fde66c5f3c2781781e7c8.zip
* Update to 0.97.0
* Add optional libdvdnav support [1] PR: 51208 [1] Submitted by: maintainer [1] Approved by: maintainer
Diffstat (limited to 'multimedia/totem/Makefile')
-rw-r--r--multimedia/totem/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index fc9252cd837a..cfba949b12ac 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= totem
-PORTVERSION= 0.96.0
+PORTVERSION= 0.97.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.96
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.97
DIST_SUBDIR= gnome2
MAINTAINER= hendrik@scholz.net
@@ -25,4 +25,20 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libdvdnav.so)
+WITH_DVDNAV= yes
+.endif
+
+.if defined(WITH_DVDNAV)
+LIB_DEPENDS+= dvdnav.1:${PORTSDIR}/multimedia/libdvdnav
+.endif
+
+.if !defined(WITH_DVDNAV)
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can enable DVD support by defining WITH_DVDNAV"
+.endif
+
+.include <bsd.port.post.mk>