aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /multimedia/totem
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile27
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-browser-plugin_Makefile.in124
-rw-r--r--multimedia/totem/files/patch-browser-plugin_idl_Makefile.in11
-rw-r--r--multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp10
-rw-r--r--multimedia/totem/files/patch-browser-plugin_totemPluginGlue.cpp20
-rw-r--r--multimedia/totem/files/patch-configure29
-rw-r--r--multimedia/totem/files/patch-src_totem.c14
-rw-r--r--multimedia/totem/pkg-descr2
-rw-r--r--multimedia/totem/pkg-plist79
10 files changed, 109 insertions, 213 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index b9e298cac084..8cecbf0f9cb7 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -3,12 +3,12 @@
# Whom: Hendrik Scholz <hendrik@scholz.net>
#
# $FreeBSD$
-# $MCom: ports/multimedia/totem/Makefile,v 1.89 2007/10/17 17:22:32 mezz Exp $
+# $MCom: ports/multimedia/totem/Makefile,v 1.102 2008/03/16 06:11:13 mezz Exp $
#
PORTNAME= totem
-PORTVERSION= 2.20.3
-PORTREVISION?= 0
+PORTVERSION= 2.22.0
+PORTREVISION?= 1
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,14 +18,15 @@ COMMENT?= A gstreamer-based video player for the GNOME 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
- hal.1:${PORTSDIR}/sysutils/hal
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+ totem-plparser.10:${PORTSDIR}/multimedia/totem-pl-parser
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
+ ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon
USE_BZIP2= yes
USE_GETTEXT= yes
USE_XLIB= yes
-USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
- nautiluscdburner ltverhack gnomecontrolcenter2
+USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
+ nautiluscdburner ltverhack pygtk2
GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
INSTALLS_ICONS= yes
@@ -44,7 +45,8 @@ GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
CONFLICTS?= totem-gstreamer-[0-9]* totem-xine-[0-9]*
OPTIONS= LIRC "Enable lirc support" off \
- GALAGO "Enable Galago support" off
+ GALAGO "Enable Galago support" off \
+ GECKO_PLUGINS "Enable install plugins for gecko browser" on
TOTEM_PLUGINS= screensaver ontop gromit media-player-keys properties sidebar-test skipto
@@ -66,15 +68,15 @@ TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
PLIST_SUB+= GALAGO="@comment "
.endif
-.if defined(WITH_MOZILLA_PLUGIN) && ${SLAVE_PORT:L}=="yes"
+.if !defined(WITHOUT_GECKO_PLUGINS)
USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
CONFIGURE_ARGS+=--with-mozilla=${GECKO} \
+ --enable-browser-plugins \
--enable-gmp-plugin \
--enable-complex-plugin \
--enable-narrowspace-plugin
-BUILD_WRKSRC= ${WRKSRC}/browser-plugin
-INSTALL_WRKSRC= ${WRKSRC}/browser-plugin
+PLIST_SUB+= GECKO_PLUGINS=""
.else
CONFIGURE_ARGS+=--without-mozilla \
--disable-browser-plugins \
@@ -83,6 +85,7 @@ CONFIGURE_ARGS+=--without-mozilla \
--disable-gmp-plugin \
--disable-complex-plugin \
--disable-narrowspace-plugin
+PLIST_SUB+= GECKO_PLUGINS="@comment "
.endif
.if !defined(WITH_TOTEM_XINE) || ${SLAVE_PORT}=="no"
@@ -125,7 +128,7 @@ post-patch:
post-install:
@-update-desktop-database
${MKDIR} ${PREFIX}/share/vala/vapi
- ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vala ${PREFIX}/share/vala/vapi
+ ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vapi ${PREFIX}/share/vala/vapi
${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.deps ${PREFIX}/share/vala/vapi
.include <bsd.port.post.mk>
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index dd21349ccd2b..8be34337d3d9 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-2.20.3.tar.bz2) = 7360e0856042615c7c1c3baf03d50bbf
-SHA256 (gnome2/totem-2.20.3.tar.bz2) = 9d51de9549c9913f91c34986f31edf55f7604e2f784e9ceea783f6102b140897
-SIZE (gnome2/totem-2.20.3.tar.bz2) = 2194842
+MD5 (gnome2/totem-2.22.0.tar.bz2) = 21a3f983e762b34db035edbaaba9dd63
+SHA256 (gnome2/totem-2.22.0.tar.bz2) = b0f9dd826089fc976ed4e57723613fb518f84e79c3f7cc7a0814b7254911f351
+SIZE (gnome2/totem-2.22.0.tar.bz2) = 2321288
diff --git a/multimedia/totem/files/patch-browser-plugin_Makefile.in b/multimedia/totem/files/patch-browser-plugin_Makefile.in
deleted file mode 100644
index df0d82b25039..000000000000
--- a/multimedia/totem/files/patch-browser-plugin_Makefile.in
+++ /dev/null
@@ -1,124 +0,0 @@
---- browser-plugin/Makefile.in.orig 2007-09-16 18:59:35.000000000 -0400
-+++ browser-plugin/Makefile.in 2007-09-16 19:00:59.000000000 -0400
-@@ -69,7 +69,7 @@
- pluginLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(noinst_LTLIBRARIES) $(plugin_LTLIBRARIES)
- am__DEPENDENCIES_1 =
--@ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_DEPENDENCIES = \
- @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -89,7 +89,7 @@
- $(libtotem_basic_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
- @ENABLE_BASIC_PLUGIN_TRUE@am_libtotem_basic_plugin_la_rpath = -rpath \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(plugindir)
--@ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_DEPENDENCIES = \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -109,7 +109,7 @@
- $(libtotem_complex_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
- @ENABLE_COMPLEX_PLUGIN_TRUE@am_libtotem_complex_plugin_la_rpath = \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ -rpath $(plugindir)
--@ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_DEPENDENCIES = \
- @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_GMP_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
- @ENABLE_GMP_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -133,7 +133,7 @@
- $(libtotem_gmp_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
- @ENABLE_GMP_PLUGIN_TRUE@am_libtotem_gmp_plugin_la_rpath = -rpath \
- @ENABLE_GMP_PLUGIN_TRUE@ $(plugindir)
--@ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_DEPENDENCIES = \
- @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -153,7 +153,7 @@
- $(libtotem_mully_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
- @ENABLE_MULLY_PLUGIN_TRUE@am_libtotem_mully_plugin_la_rpath = -rpath \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(plugindir)
--@ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_DEPENDENCIES = \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -198,10 +198,6 @@
- totem_plugin_viewer-totem-plugin-viewer.$(OBJEXT)
- totem_plugin_viewer_OBJECTS = $(am_totem_plugin_viewer_OBJECTS)
- totem_plugin_viewer_DEPENDENCIES = \
-- $(top_builddir)/src/backend/libbaconvideowidget.la \
-- $(top_builddir)/src/libtotem_player.la \
-- $(top_builddir)/src/plparse/libtotem-plparser.la \
-- $(top_builddir)/lib/libtotemscrsaver.la \
- libtotempluginviewer_helper.la $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
-@@ -381,7 +377,7 @@
- MOZILLA_LIBDIR = @MOZILLA_LIBDIR@
- MOZILLA_NOT_LINKED_CFLAGS = @MOZILLA_NOT_LINKED_CFLAGS@
- MOZILLA_NOT_LINKED_LIBS = @MOZILLA_NOT_LINKED_LIBS@
--MOZILLA_PLUGINDIR = @MOZILLA_PLUGINDIR@
-+MOZILLA_PLUGINDIR = $(libdir)/browser_plugins
- MOZILLA_PREFIX = @MOZILLA_PREFIX@
- MOZILLA_XPCOM_CFLAGS = @MOZILLA_XPCOM_CFLAGS@
- MOZILLA_XPIDL = @MOZILLA_XPIDL@
-@@ -599,10 +595,7 @@
- $(AM_CFLAGS)
-
- totem_plugin_viewer_LDADD = \
-- $(top_builddir)/src/backend/libbaconvideowidget.la \
-- $(top_builddir)/src/libtotem_player.la \
-- $(top_builddir)/src/plparse/libtotem-plparser.la \
-- $(top_builddir)/lib/libtotemscrsaver.la \
-+ -ltotem-plparser \
- libtotempluginviewer_helper.la \
- $(EXTRA_GNOME_LIBS) \
- $(XVIDMODE_LIBS) \
-@@ -654,7 +647,7 @@
- @ENABLE_BASIC_PLUGIN_TRUE@ $(AM_CXXFLAGS)
-
- @ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_LIBADD = \
--@ENABLE_BASIC_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_BASIC_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -715,7 +708,7 @@
- @ENABLE_GMP_PLUGIN_TRUE@ $(AM_CXXFLAGS)
-
- @ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_LIBADD = \
--@ENABLE_GMP_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_GMP_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_GMP_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_GMP_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -770,7 +763,7 @@
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(AM_CXXFLAGS)
-
- @ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_LIBADD = \
--@ENABLE_COMPLEX_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_COMPLEX_PLUGIN_TRUE@ -ltotem-plparser
- @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -825,7 +818,7 @@
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(AM_CXXFLAGS)
-
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_LIBADD = \
--@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_NARROWSPACE_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -880,7 +873,7 @@
- @ENABLE_MULLY_PLUGIN_TRUE@ $(AM_CXXFLAGS)
-
- @ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_LIBADD = \
--@ENABLE_MULLY_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_MULLY_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
diff --git a/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in b/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in
new file mode 100644
index 000000000000..238b32c3263a
--- /dev/null
+++ b/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in
@@ -0,0 +1,11 @@
+--- browser-plugin/idl/Makefile.in.orig 2008-03-15 20:31:26.000000000 -0500
++++ browser-plugin/idl/Makefile.in 2008-03-15 20:31:34.000000000 -0500
+@@ -532,7 +532,7 @@
+
+ info-am:
+
+-install-data-am: install-docDATA install-xptDATA
++install-data-am: install-xptDATA
+
+ install-dvi: install-dvi-am
+
diff --git a/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp b/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp
deleted file mode 100644
index 9a16349f4b0a..000000000000
--- a/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- browser-plugin/totemPlugin.cpp.orig Mon Aug 14 17:01:14 2006
-+++ browser-plugin/totemPlugin.cpp Mon Aug 14 17:01:24 2006
-@@ -27,6 +27,7 @@
- #include <stdint.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <signal.h>
- #include <sys/wait.h>
- #include <sys/poll.h>
- #include <string.h>
diff --git a/multimedia/totem/files/patch-browser-plugin_totemPluginGlue.cpp b/multimedia/totem/files/patch-browser-plugin_totemPluginGlue.cpp
new file mode 100644
index 000000000000..6e697364da2d
--- /dev/null
+++ b/multimedia/totem/files/patch-browser-plugin_totemPluginGlue.cpp
@@ -0,0 +1,20 @@
+--- browser-plugin/totemPluginGlue.cpp.orig 2008-03-15 18:00:23.000000000 -0500
++++ browser-plugin/totemPluginGlue.cpp 2008-03-15 18:01:54.000000000 -0500
+@@ -356,7 +356,7 @@
+ user_ini_file = g_build_filename (g_get_user_config_dir (),
+ "totem",
+ "browser-plugins.ini",
+- NULL);
++ (char *)NULL);
+ if (g_key_file_load_from_file (user,
+ user_ini_file,
+ G_KEY_FILE_NONE,
+@@ -439,7 +439,7 @@
+ /* we want to open libdbus-glib-1.so.2 in such a way
+ * in such a way that it becomes permanentely resident */
+ void *handle;
+- handle = dlopen ("libdbus-glib-1.so.2", RTLD_NOW | RTLD_NODELETE);
++ handle = dlopen ("libdbus-glib-1.so.2", RTLD_NOW);
+ if (!handle) {
+ fprintf (stderr, "%s\n", dlerror());
+ return NPERR_MODULE_LOAD_FAILED_ERROR;
diff --git a/multimedia/totem/files/patch-configure b/multimedia/totem/files/patch-configure
deleted file mode 100644
index 1fab81f6ed98..000000000000
--- a/multimedia/totem/files/patch-configure
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.orig Fri May 25 00:24:10 2007
-+++ configure Fri May 25 00:24:23 2007
-@@ -22960,7 +22960,7 @@ GTK_LIBS="$GTK_LIBS $EXTRA_BACKEND_LIBS"
-
- plugin_error_or_ignore()
- {
-- if test "${error_on_bad_plugin}" == "1" ; then
-+ if test "${error_on_bad_plugin}" = "1" ; then
- { { echo "$as_me:$LINENO: error: $1" >&5
- echo "$as_me: error: $1" >&2;}
- { (exit 1); exit 1; }; }
-@@ -22982,7 +22982,7 @@ fi
- used_plugins=""
- used_plugins2=""
-
--if test "x${with_plugins}" == "xautodetect" ; then
-+if test "x${with_plugins}" = "xautodetect" ; then
- # Default to all plugins and just ignore them if they won't compile
- with_plugins="all"
- error_on_bad_plugin="0"
-@@ -23384,7 +23384,7 @@ fi
- esac
-
- # Add the specified plugin
-- if test "${add_plugin}" == "1" ; then
-+ if test "${add_plugin}" = "1" ; then
- used_plugins2="${used_plugins2} ${plugin}"
- fi
- done
diff --git a/multimedia/totem/files/patch-src_totem.c b/multimedia/totem/files/patch-src_totem.c
deleted file mode 100644
index da8b5dc31a1e..000000000000
--- a/multimedia/totem/files/patch-src_totem.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/totem.c.orig Sat Oct 21 22:10:07 2006
-+++ src/totem.c Sat Oct 21 22:11:56 2006
-@@ -339,7 +339,11 @@
-
- g_object_get (G_OBJECT (totem->bvw),
- "mediadev", &device, NULL);
-+#if defined (__FreeBSD__)
-+ cmd = g_strdup_printf ("cdcontrol -f %s eject", device);
-+#else
- cmd = g_strdup_printf ("eject %s", device);
-+#endif
- g_free (device);
-
- if (g_spawn_command_line_sync (cmd, NULL, NULL, NULL, &err) == FALSE)
diff --git a/multimedia/totem/pkg-descr b/multimedia/totem/pkg-descr
index 404246e58ab1..3f33f1f5f682 100644
--- a/multimedia/totem/pkg-descr
+++ b/multimedia/totem/pkg-descr
@@ -2,6 +2,6 @@ Totem is simple movie player for the Gnome 2 desktop based on xine.
It features a simple playlist, a full-screen mode, seek and volume controls,
as well as a pretty complete keyboard navigation.
-WWW: http://www.hadess.net/totem.php3
+WWW: http://www.gnome.org/projects/totem/
-- Hendrik Scholz <hendrik@scholz.net>
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 4124fd04a080..1d3ca28dc8f0 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -1,17 +1,34 @@
bin/totem
+bin/totem-audio-preview
bin/totem-video-indexer
bin/totem-video-thumbnailer
-include/totem/1/plparser/totem-disc.h
-include/totem/1/plparser/totem-pl-parser-builtins.h
-include/totem/1/plparser/totem-pl-parser-features.h
-include/totem/1/plparser/totem-pl-parser.h
-lib/libtotem-plparser.a
-lib/libtotem-plparser.la
-lib/libtotem-plparser.so
-lib/libtotem-plparser.so.7
-lib/nautilus/extensions-1.0/libtotem-properties-page.a
-lib/nautilus/extensions-1.0/libtotem-properties-page.la
-lib/nautilus/extensions-1.0/libtotem-properties-page.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-basic-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-basic-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-basic-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-basic-plugin.xpt
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-complex-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-complex-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-complex-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-complex-plugin.xpt
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-cone-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-cone-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-cone-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-cone-plugin.xpt
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-gmp-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-gmp-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-gmp-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-gmp-plugin.xpt
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-mully-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-mully-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-mully-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-mully-plugin.xpt
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-narrowspace-plugin.a
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-narrowspace-plugin.la
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-narrowspace-plugin.so
+%%GECKO_PLUGINS%%lib/browser_plugins/libtotem-narrowspace-plugin.xpt
+lib/nautilus/extensions-2.0/libtotem-properties-page.a
+lib/nautilus/extensions-2.0/libtotem-properties-page.la
+lib/nautilus/extensions-2.0/libtotem-properties-page.so
%%GALAGO%%lib/totem/plugins/galago/galago.totem-plugin
%%GALAGO%%lib/totem/plugins/galago/libtgp.a
%%GALAGO%%lib/totem/plugins/galago/libtgp.la
@@ -45,7 +62,11 @@ lib/totem/plugins/skipto/libskipto.la
lib/totem/plugins/skipto/libskipto.so
lib/totem/plugins/skipto/skipto.totem-plugin
lib/totem/plugins/skipto/skipto.ui
-libdata/pkgconfig/totem-plparser.pc
+lib/totem/plugins/totem/__init__.py
+lib/totem/plugins/totem/__init__.pyc
+lib/totem/plugins/totem/__init__.pyo
+%%GECKO_PLUGINS%%libexec/totem-plugin-viewer
+libexec/totem/totem-bugreport.py
share/applications/totem.desktop
share/gnome/help/totem/C/figures/totem_next_button.png
share/gnome/help/totem/C/figures/totem_pause_button.png
@@ -105,6 +126,15 @@ share/gnome/help/totem/fr/figures/totem_start_window.png
share/gnome/help/totem/fr/figures/totem_volume_maximum_button.png
share/gnome/help/totem/fr/figures/totem_volume_mute_button.png
share/gnome/help/totem/fr/totem.xml
+share/gnome/help/totem/it/figures/totem_next_button.png
+share/gnome/help/totem/it/figures/totem_pause_button.png
+share/gnome/help/totem/it/figures/totem_play_button.png
+share/gnome/help/totem/it/figures/totem_previous_button.png
+share/gnome/help/totem/it/figures/totem_show_playlist_button.png
+share/gnome/help/totem/it/figures/totem_start_window.png
+share/gnome/help/totem/it/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/it/figures/totem_volume_mute_button.png
+share/gnome/help/totem/it/totem.xml
share/gnome/help/totem/oc/figures/totem_next_button.png
share/gnome/help/totem/oc/figures/totem_pause_button.png
share/gnome/help/totem/oc/figures/totem_play_button.png
@@ -163,9 +193,11 @@ share/icons/hicolor/16x16/apps/totem.png
share/icons/hicolor/22x22/apps/totem.png
share/icons/hicolor/24x24/apps/totem.png
share/icons/hicolor/32x32/apps/totem.png
+share/icons/hicolor/48x48/apps/totem.png
share/icons/hicolor/scalable/apps/totem.svg
share/locale/am/LC_MESSAGES/totem.mo
share/locale/ar/LC_MESSAGES/totem.mo
+share/locale/as/LC_MESSAGES/totem.mo
share/locale/az/LC_MESSAGES/totem.mo
share/locale/be/LC_MESSAGES/totem.mo
share/locale/be@latin/LC_MESSAGES/totem.mo
@@ -200,6 +232,7 @@ share/locale/is/LC_MESSAGES/totem.mo
share/locale/it/LC_MESSAGES/totem.mo
share/locale/ja/LC_MESSAGES/totem.mo
share/locale/ka/LC_MESSAGES/totem.mo
+share/locale/kn/LC_MESSAGES/totem.mo
share/locale/ko/LC_MESSAGES/totem.mo
share/locale/ku/LC_MESSAGES/totem.mo
share/locale/lt/LC_MESSAGES/totem.mo
@@ -222,6 +255,7 @@ share/locale/pt_BR/LC_MESSAGES/totem.mo
share/locale/ro/LC_MESSAGES/totem.mo
share/locale/ru/LC_MESSAGES/totem.mo
share/locale/rw/LC_MESSAGES/totem.mo
+share/locale/si/LC_MESSAGES/totem.mo
share/locale/sk/LC_MESSAGES/totem.mo
share/locale/sl/LC_MESSAGES/totem.mo
share/locale/sq/LC_MESSAGES/totem.mo
@@ -247,6 +281,7 @@ share/omf/totem/totem-de.omf
share/omf/totem/totem-en_GB.omf
share/omf/totem/totem-es.omf
share/omf/totem/totem-fr.omf
+share/omf/totem/totem-it.omf
share/omf/totem/totem-oc.omf
share/omf/totem/totem-pa.omf
share/omf/totem/totem-pt_BR.omf
@@ -258,16 +293,15 @@ share/omf/totem/totem-uk.omf
%%DATADIR%%/filmholes.png
%%DATADIR%%/fullscreen.ui
%%DATADIR%%/mozilla-viewer.ui
-%%DATADIR%%/playlist-ui.xml
%%DATADIR%%/playlist.ui
%%DATADIR%%/plugins.ui
%%DATADIR%%/properties.ui
-%%DATADIR%%/totem-ui.xml
%%DATADIR%%/totem.ui
%%DATADIR%%/totem_logo.png
%%DATADIR%%/uri.ui
+%%DATADIR%%/video-list.ui
share/vala/vapi/totem.deps
-share/vala/vapi/totem.vala
+share/vala/vapi/totem.vapi
@dirrm %%DATADIR%%
@dirrm share/omf/totem
@dirrm share/gnome/help/totem/uk/figures
@@ -282,6 +316,8 @@ share/vala/vapi/totem.vala
@dirrm share/gnome/help/totem/pa
@dirrm share/gnome/help/totem/oc/figures
@dirrm share/gnome/help/totem/oc
+@dirrm share/gnome/help/totem/it/figures
+@dirrm share/gnome/help/totem/it
@dirrm share/gnome/help/totem/fr/figures
@dirrm share/gnome/help/totem/fr
@dirrm share/gnome/help/totem/es/figures
@@ -297,6 +333,8 @@ share/vala/vapi/totem.vala
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem
+@dirrm libexec/totem
+@dirrm lib/totem/plugins/totem
@dirrm lib/totem/plugins/skipto
@dirrm lib/totem/plugins/screensaver
@dirrm lib/totem/plugins/properties
@@ -307,12 +345,10 @@ share/vala/vapi/totem.vala
%%GALAGO%%@dirrm lib/totem/plugins/galago
@dirrm lib/totem/plugins
@dirrm lib/totem
-@dirrmtry lib/browser_plugins
-@dirrm include/totem/1/plparser
-@dirrm include/totem/1
-@dirrm include/totem
+%%GECKO_PLUGINS%%@dirrmtry lib/browser_plugins
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@@ -321,6 +357,8 @@ share/vala/vapi/totem.vala
@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@@ -337,4 +375,5 @@ share/vala/vapi/totem.vala
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
-@dirrmtry share/applications
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as