aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/toxine
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-05-05 00:47:35 +0800
committeralepulver <alepulver@FreeBSD.org>2006-05-05 00:47:35 +0800
commitaa161866534d442845b06b1830b85855dc7029b2 (patch)
tree80ef3c8c648fb1273757f35f1cd00a2c0d54516c /multimedia/toxine
parent8b878a21d95daf507e5841fc5806d6a50cf4547e (diff)
downloadfreebsd-ports-gnome-aa161866534d442845b06b1830b85855dc7029b2.tar.gz
freebsd-ports-gnome-aa161866534d442845b06b1830b85855dc7029b2.tar.zst
freebsd-ports-gnome-aa161866534d442845b06b1830b85855dc7029b2.zip
- Remove USE_REINPLACE.
- Format tabs, put targets at the end. - Remove unavoidable auto-detection of OPTIONS. - Change libxine library version (13 -> 15) in dependency. Approved by: garga (mentor)
Diffstat (limited to 'multimedia/toxine')
-rw-r--r--multimedia/toxine/Makefile47
1 files changed, 20 insertions, 27 deletions
diff --git a/multimedia/toxine/Makefile b/multimedia/toxine/Makefile
index 4146f010e07e..c2e5733c998b 100644
--- a/multimedia/toxine/Makefile
+++ b/multimedia/toxine/Makefile
@@ -15,10 +15,9 @@ MASTER_SITE_SUBDIR= toxine
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Text user interface using the xine library
-LIB_DEPENDS= xine.13:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine
USE_X_PREFIX= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -34,7 +33,7 @@ OPTIONS= AALIB "Enable aalib support" on \
.if ${OSVERSION} < 502000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
+CONFIGURE_ARGS+=--with-readline=${LOCALBASE}
.endif
.if ${OSVERSION} < 500000
@@ -43,40 +42,34 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-main.c
.if !defined(WITHOUT_AALIB)
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+PLIST_SUB+= AALIB=""
+.else
+PLIST_SUB+= AALIB="@comment "
.endif
.if !defined(WITHOUT_LIBCACA)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
+PLIST_SUB+= LIBCACA=""
+.else
+PLIST_SUB+= LIBCACA="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|alsa09|oss|g' ${WRKSRC}/misc/dvdplayer.sh.in
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-mpreferred-stack-boundary=2||g ; \
- s|-fno-strict-aliasing||g ; \
- s|-fschedule-insns2||g ; \
- s|-mwide-multiply||g ; \
- s|-falign-functions=4||g ; \
- s|-falign-loops=4||g ; \
- s|-falign-jumps=4||g ; \
- s|-fomit-frame-pointer||g ; \
- s|-fexpensive-optimizations||g ; \
- s|-ffast-math||g ; \
- s|-funroll-loops||g ; \
- s|-finline-functions||g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
-
-.if defined(WITH_AALIB) || exists(${LOCALBASE}/lib/libaa.a)
-PLIST_SUB+= AALIB=""
-.else
-PLIST_SUB+= AALIB="@comment "
-.endif
-
-.if defined(WITH_LIBCACA) || exists(${LOCALBASE}/lib/libcaca.a)
-PLIST_SUB+= LIBCACA=""
-.else
-PLIST_SUB+= LIBCACA="@comment "
+ s|-fno-strict-aliasing||g ; \
+ s|-fschedule-insns2||g ; \
+ s|-mwide-multiply||g ; \
+ s|-falign-functions=4||g ; \
+ s|-falign-loops=4||g ; \
+ s|-falign-jumps=4||g ; \
+ s|-fomit-frame-pointer||g ; \
+ s|-fexpensive-optimizations||g ; \
+ s|-ffast-math||g ; \
+ s|-funroll-loops||g ; \
+ s|-finline-functions||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
.include <bsd.port.post.mk>