aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/toxine
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-06 19:49:00 +0800
committerpav <pav@FreeBSD.org>2005-07-06 19:49:00 +0800
commit52664199cff2890949aa49657ea96cc36e7b4564 (patch)
tree982f688dc407fd18441568fbf24ec7d55c7b2672 /multimedia/toxine
parent60825e09e7112f837a9028dfefc482bf5d914ee7 (diff)
downloadfreebsd-ports-gnome-52664199cff2890949aa49657ea96cc36e7b4564.tar.gz
freebsd-ports-gnome-52664199cff2890949aa49657ea96cc36e7b4564.tar.zst
freebsd-ports-gnome-52664199cff2890949aa49657ea96cc36e7b4564.zip
Toxine is a text user interface using the xine library. It permit to playback
all streams that xine supports, in interactive or in script mode (using toxine syntax). It use xine's visualisation plugins (AAlib, X11, DXR3/HW+), and/or his own 'none' one (audio only output). PR: ports/82951 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'multimedia/toxine')
-rw-r--r--multimedia/toxine/Makefile84
-rw-r--r--multimedia/toxine/distinfo2
-rw-r--r--multimedia/toxine/files/extra-patch-main.c13
-rw-r--r--multimedia/toxine/pkg-descr23
-rw-r--r--multimedia/toxine/pkg-plist9
5 files changed, 131 insertions, 0 deletions
diff --git a/multimedia/toxine/Makefile b/multimedia/toxine/Makefile
new file mode 100644
index 000000000000..caf9dfd85a46
--- /dev/null
+++ b/multimedia/toxine/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: multimedia/toxine
+# Date created: 3 August 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= toxine
+PORTVERSION= 0.6.3
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= toxine
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Text user interface using the xine library
+
+LIB_DEPENDS= xine.13:${PORTSDIR}/multimedia/libxine
+
+# configure rejects amd64
+ONLY_FOR_ARCHS= i386
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
+
+MAN1= toxine.1
+
+OPTIONS= AALIB "Enable aalib support" on \
+ LIBCACA "Enable libcaca support" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
+.endif
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-main.c
+.endif
+
+.if !defined(WITHOUT_AALIB)
+LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+.endif
+
+.if !defined(WITHOUT_LIBCACA)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|alsa09|oss|g' ${WRKSRC}/misc/dvdplayer.sh.in
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-mpreferred-stack-boundary=2||g ; \
+ s|-fno-strict-aliasing||g ; \
+ s|-fschedule-insns2||g ; \
+ s|-mwide-multiply||g ; \
+ s|-falign-functions=4||g ; \
+ s|-falign-loops=4||g ; \
+ s|-falign-jumps=4||g ; \
+ s|-fomit-frame-pointer||g ; \
+ s|-fexpensive-optimizations||g ; \
+ s|-ffast-math||g ; \
+ s|-funroll-loops||g ; \
+ s|-finline-functions||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+.if defined(WITH_AALIB) || exists(${LOCALBASE}/lib/libaa.a)
+PLIST_SUB+= AALIB=""
+.else
+PLIST_SUB+= AALIB="@comment "
+.endif
+
+.if defined(WITH_LIBCACA) || exists(${LOCALBASE}/lib/libcaca.a)
+PLIST_SUB+= LIBCACA=""
+.else
+PLIST_SUB+= LIBCACA="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/toxine/distinfo b/multimedia/toxine/distinfo
new file mode 100644
index 000000000000..80a624127101
--- /dev/null
+++ b/multimedia/toxine/distinfo
@@ -0,0 +1,2 @@
+MD5 (toxine-0.6.3.tar.gz) = 261c6ac24f77337a9311d39f42fb5be4
+SIZE (toxine-0.6.3.tar.gz) = 342432
diff --git a/multimedia/toxine/files/extra-patch-main.c b/multimedia/toxine/files/extra-patch-main.c
new file mode 100644
index 000000000000..b0fa8b5aa284
--- /dev/null
+++ b/multimedia/toxine/files/extra-patch-main.c
@@ -0,0 +1,13 @@
+FreeBSD 4.X does not have O_SYNC yet
+
+--- src/main.c.orig Mon Apr 12 17:55:02 2004
++++ src/main.c Wed Jul 6 12:16:42 2005
+@@ -207,7 +207,7 @@
+ {
+ char *ofile = (optarg) ? optarg : "toxine.out";
+
+- if((tox->msg_fd = open(ofile, O_WRONLY | O_CREAT | O_TRUNC | O_SYNC, 0644)) < 0) {
++ if((tox->msg_fd = open(ofile, O_WRONLY | O_CREAT | O_TRUNC | O_FSYNC, 0644)) < 0) {
+ fprintf(stderr, "Cannot open %s: %s\n", ofile, strerror(errno));
+ exit(1);
+ }
diff --git a/multimedia/toxine/pkg-descr b/multimedia/toxine/pkg-descr
new file mode 100644
index 000000000000..23eab79d5aa3
--- /dev/null
+++ b/multimedia/toxine/pkg-descr
@@ -0,0 +1,23 @@
+Toxine is a text user interface using the xine library. It permit to playback
+all streams that xine supports, in interactive or in script mode (using
+toxine syntax). It use xine's visualisation plugins (AAlib, X11, DXR3/HW+),
+and/or his own 'none' one (audio only output).
+
+It use the readline library, which permit, in interactive mode, to recall
+commands, completions, etc..
+
+You can use it in a console (useful for DXR3/HW+ owners, using TV output), or
+in a X11 terminal window.
+If you're a developper, and you want to test/debug your own plugins, using
+toxine is useful due of script usage. This way, you can reproduce actions
+without interactions, redirect outputs to a file (name given or not). You can
+also see how to implement your own xine library frontend, because toxine
+implement almost all xine's API calls.
+
+If you don't like GUIs, or love console (and AAlib video output), toxine is
+for you ;-)
+
+WWW: http://toxine.sourceforge.net/
+
+- Alejandro Pulver
+alejandro@vanet.biz
diff --git a/multimedia/toxine/pkg-plist b/multimedia/toxine/pkg-plist
new file mode 100644
index 000000000000..b75be3b80c4d
--- /dev/null
+++ b/multimedia/toxine/pkg-plist
@@ -0,0 +1,9 @@
+bin/dvdplayer.sh
+bin/toxine
+%%AALIB%%lib/toxine/plugins/toxine_vo_plugin_aa.so
+%%LIBCACA%%lib/toxine/plugins/toxine_vo_plugin_caca.so
+lib/toxine/plugins/toxine_vo_plugin_dxr3.so
+lib/toxine/plugins/toxine_vo_plugin_none.so
+lib/toxine/plugins/toxine_vo_plugin_x11.so
+@dirrm lib/toxine/plugins
+@dirrm lib/toxine