aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/transcode
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2007-07-31 23:34:10 +0800
committerahze <ahze@FreeBSD.org>2007-07-31 23:34:10 +0800
commit7292a46a4e220805e9473db18b0c8dacc8563a7d (patch)
tree6010e27b5f72f701245c2dc528f35bf105dbf87a /multimedia/transcode
parent87b6e213ab0531f85d7ac394c16b11119c4ab080 (diff)
downloadfreebsd-ports-gnome-7292a46a4e220805e9473db18b0c8dacc8563a7d.tar.gz
freebsd-ports-gnome-7292a46a4e220805e9473db18b0c8dacc8563a7d.tar.zst
freebsd-ports-gnome-7292a46a4e220805e9473db18b0c8dacc8563a7d.zip
Fix build/runtime with new ffmpeg
Reported by: pav Obtained from: transcode cvs
Diffstat (limited to 'multimedia/transcode')
-rw-r--r--multimedia/transcode/Makefile2
-rw-r--r--multimedia/transcode/files/patch-export_aud_aux.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index e1925fcd9694..6a68425cadd9 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= transcode
PORTVERSION= 1.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://fromani.exit1.org/
diff --git a/multimedia/transcode/files/patch-export_aud_aux.c b/multimedia/transcode/files/patch-export_aud_aux.c
new file mode 100644
index 000000000000..3056c88414d5
--- /dev/null
+++ b/multimedia/transcode/files/patch-export_aud_aux.c
@@ -0,0 +1,12 @@
+--- export/aud_aux.c.orig 2007-07-31 10:11:13.000000000 -0400
++++ export/aud_aux.c 2007-07-31 10:10:10.000000000 -0400
+@@ -361,8 +361,7 @@
+
+ pthread_mutex_lock(&init_avcodec_lock);
+ avcodec_init();
+- register_avcodec(&ac3_encoder);
+- register_avcodec(&mp2_encoder);
++ avcodec_register_all();
+ pthread_mutex_unlock(&init_avcodec_lock);
+
+ switch (o_codec) {