aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/v4l_compat
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2012-06-29 01:49:51 +0800
committernox <nox@FreeBSD.org>2012-06-29 01:49:51 +0800
commit349357b0704a96b648afe1e0544148c5e82d6e63 (patch)
tree6193c8acce2779177b80527b251aa2a630490640 /multimedia/v4l_compat
parentac91c810bc8351eda5fa2f1e3ce83eb11c0f2254 (diff)
downloadfreebsd-ports-gnome-349357b0704a96b648afe1e0544148c5e82d6e63.tar.gz
freebsd-ports-gnome-349357b0704a96b648afe1e0544148c5e82d6e63.tar.zst
freebsd-ports-gnome-349357b0704a96b648afe1e0544148c5e82d6e63.zip
- Fix two linux/dvb ioctls in multimedia/v4l_compat , multimedia/webcamd ,
and multimedia/linux_dvbwrapper : CA_GET_SLOT_INFO and CA_GET_MSG need to be _IOWR not _IOR. - Bump PORTREVISION for multimedia/vdr too since it uses one of the ioctls. (This fixes the CI slot of at last the TT CT-3650 DVB-C/T tuner.) Approved by: hselasky (maintainer of multimedia/webcamd)
Diffstat (limited to 'multimedia/v4l_compat')
-rw-r--r--multimedia/v4l_compat/Makefile1
-rw-r--r--multimedia/v4l_compat/files/patch-dvb-ca.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/multimedia/v4l_compat/Makefile b/multimedia/v4l_compat/Makefile
index b9c3de8d5b9d..0933530c53d6 100644
--- a/multimedia/v4l_compat/Makefile
+++ b/multimedia/v4l_compat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= v4l_compat
PORTVERSION= 1.0.${DUMMYDATE}
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= LOCAL/kwm
diff --git a/multimedia/v4l_compat/files/patch-dvb-ca.h b/multimedia/v4l_compat/files/patch-dvb-ca.h
new file mode 100644
index 000000000000..bc42f2e9cdca
--- /dev/null
+++ b/multimedia/v4l_compat/files/patch-dvb-ca.h
@@ -0,0 +1,20 @@
+--- dvb/ca.h.orig
++++ dvb/ca.h
+@@ -80,9 +80,17 @@ typedef struct ca_pid {
+
+ #define CA_RESET _IO('o', 128)
+ #define CA_GET_CAP _IOR('o', 129, ca_caps_t)
++
++/* At least CA_GET_SLOT_INFO and CA_GET_MSG need to be _IOWR not _IOR.
++ * This is wrong on Linux too but there the driver doesn't care.
++ *
+ #define CA_GET_SLOT_INFO _IOR('o', 130, ca_slot_info_t)
+ #define CA_GET_DESCR_INFO _IOR('o', 131, ca_descr_info_t)
+ #define CA_GET_MSG _IOR('o', 132, ca_msg_t)
++ */
++#define CA_GET_SLOT_INFO _IOWR('o', 130, ca_slot_info_t)
++#define CA_GET_DESCR_INFO _IOR('o', 131, ca_descr_info_t)
++#define CA_GET_MSG _IOWR('o', 132, ca_msg_t)
+ #define CA_SEND_MSG _IOW('o', 133, ca_msg_t)
+ #define CA_SET_DESCR _IOW('o', 134, ca_descr_t)
+ #define CA_SET_PID _IOW('o', 135, ca_pid_t)