aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vamps/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-01-04 18:24:47 +0800
committerlioux <lioux@FreeBSD.org>2006-01-04 18:24:47 +0800
commitb7bfb266d4a43fbd86662bc02a2b398861baa898 (patch)
tree7a3136afb7954deec47b45545bcc8d8fa411a1cd /multimedia/vamps/Makefile
parentb490a46e039529bdbaa6fbaa3eaeac54d9dd6e11 (diff)
downloadfreebsd-ports-gnome-b7bfb266d4a43fbd86662bc02a2b398861baa898.tar.gz
freebsd-ports-gnome-b7bfb266d4a43fbd86662bc02a2b398861baa898.tar.zst
freebsd-ports-gnome-b7bfb266d4a43fbd86662bc02a2b398861baa898.zip
New port vamps version 0.98: High performance tool to transcode DVD
videos to a smaller size
Diffstat (limited to 'multimedia/vamps/Makefile')
-rw-r--r--multimedia/vamps/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/multimedia/vamps/Makefile b/multimedia/vamps/Makefile
new file mode 100644
index 000000000000..2d0aa5d58c85
--- /dev/null
+++ b/multimedia/vamps/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: vamps
+# Date created: Fri Dec 16 04:38:13 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vamps
+PORTVERSION= 0.98
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= vamps
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= High performance tool to transcode DVD videos to a smaller size
+
+LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
+
+CONFLICTS= lxdvdrip-{{0.,1.[0-3],1.4[0-7]}*
+
+USE_GMAKE= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+
+CFLAGS+= -DHAVE_BUILTIN_EXPECT \
+ -I${LOCALBASE}/include \
+ ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib \
+ ${PTHREAD_LIBS}
+
+PROGRAM_FILES= \
+ play_cell/play_cell \
+ vamps/vamps
+
+PLIST_FILES= ${PROGRAM_FILES:H:S,^,bin/,}
+
+do-install:
+.for program in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${program} ${PREFIX}/bin/${program:H}
+.endfor
+
+.include <bsd.port.mk>