aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vdr-plugin-control
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2014-03-01 20:21:13 +0800
committernox <nox@FreeBSD.org>2014-03-01 20:21:13 +0800
commit0d223bacfca172777b73d5212eddc8acd2346600 (patch)
tree5b514c92c45cfe80c1cae5cd74f5bbac9f011628 /multimedia/vdr-plugin-control
parent3f142a1bb1df94b31dfb7cf21fb9262faecef608 (diff)
downloadfreebsd-ports-gnome-0d223bacfca172777b73d5212eddc8acd2346600.tar.gz
freebsd-ports-gnome-0d223bacfca172777b73d5212eddc8acd2346600.tar.zst
freebsd-ports-gnome-0d223bacfca172777b73d5212eddc8acd2346600.zip
- Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax. - Change multimedia/vdr-plugins defaults and bump PORTREVISION for it. (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
Diffstat (limited to 'multimedia/vdr-plugin-control')
-rw-r--r--multimedia/vdr-plugin-control/Makefile10
-rw-r--r--multimedia/vdr-plugin-control/files/patch-Makefile2
2 files changed, 6 insertions, 6 deletions
diff --git a/multimedia/vdr-plugin-control/Makefile b/multimedia/vdr-plugin-control/Makefile
index 262b9ff36b50..d794254ce839 100644
--- a/multimedia/vdr-plugin-control/Makefile
+++ b/multimedia/vdr-plugin-control/Makefile
@@ -22,7 +22,6 @@ HAVE_CONFIGURE= yes
PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION:S/a45/a/}
-NO_STAGE= yes
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
@@ -31,10 +30,11 @@ post-patch: post-patch-plugin
${PATCH} -d ${WRKSRC} `${SED} -n '/^#PATCHOPTIONS:/{s///;p;q;}' $$i` --forward --quiet <$$i ;\
done
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-control/files/patch-Makefile b/multimedia/vdr-plugin-control/files/patch-Makefile
index df1ed41927b4..e3d3022bf5a5 100644
--- a/multimedia/vdr-plugin-control/files/patch-Makefile
+++ b/multimedia/vdr-plugin-control/files/patch-Makefile
@@ -16,7 +16,7 @@
+APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
+
+install:
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
+
### Implicit rules: