aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vdr-plugin-infosatepg
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-05-11 01:35:36 +0800
committernox <nox@FreeBSD.org>2011-05-11 01:35:36 +0800
commit63deb30c499a007c5234e0b29f203178ae0984fa (patch)
tree8ad0d938d809d83f32e3a8adcf3becca544b1277 /multimedia/vdr-plugin-infosatepg
parente8eb3610adea1d588a77aaa0e55c08fd84f147ac (diff)
downloadfreebsd-ports-gnome-63deb30c499a007c5234e0b29f203178ae0984fa.tar.gz
freebsd-ports-gnome-63deb30c499a007c5234e0b29f203178ae0984fa.tar.zst
freebsd-ports-gnome-63deb30c499a007c5234e0b29f203178ae0984fa.zip
- Add bugfix for infosatepg grabbing a non-first tuner device that
still was in use. (like when the sat tuner was on /dev/dvb/adapter8.) - Bump PORTREVISION.
Diffstat (limited to 'multimedia/vdr-plugin-infosatepg')
-rw-r--r--multimedia/vdr-plugin-infosatepg/Makefile2
-rw-r--r--multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp9
2 files changed, 10 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-infosatepg/Makefile b/multimedia/vdr-plugin-infosatepg/Makefile
index aff2084d3b44..39e232c11f49 100644
--- a/multimedia/vdr-plugin-infosatepg/Makefile
+++ b/multimedia/vdr-plugin-infosatepg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-infosatepg
PORTVERSION= 0.0.11
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/342/
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
diff --git a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
index 620910c6656e..8e33a6a351d0 100644
--- a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
+++ b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
@@ -1,5 +1,14 @@
--- a/infosatepg.cpp
+++ b/infosatepg.cpp
+@@ -193,7 +193,7 @@ void cPluginInfosatepg::MainThreadHook(v
+ if (EITScanner.UsesDevice(dev)) continue; // EITScanner is updating EPG -> skip
+ if (dev->Receiving()) continue; // device is recording -> skip
+ if (dev->IsPrimaryDevice()) continue; // device is primary -> skip
+- if (cDevice::ActualDevice()->CardIndex()==i) continue; // device is live viewing -> skip
++ if (cDevice::ActualDevice()->CardIndex()==dev->CardIndex()) continue; // device is live viewing -> skip
+ if (dev->IsTunedToTransponder(chan))
+ {
+ // we already have a device which is tuned (maybe switched manually?)
@@ -403,7 +403,7 @@ cString cPluginInfosatepg::SVDRPCommand(
cString head2;
head2="\n" \