aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/vlc-devel/Makefile
diff options
context:
space:
mode:
authorbrian <brian@FreeBSD.org>2001-08-07 07:05:58 +0800
committerbrian <brian@FreeBSD.org>2001-08-07 07:05:58 +0800
commit834ed838280978e68a7d0e449c58336901c1a149 (patch)
treed4f61a88014a9913a28ace84f0a362554621e71c /multimedia/vlc-devel/Makefile
parentd14eae3ac5fc9c307698a18d51e69b551ebe2ba9 (diff)
downloadfreebsd-ports-gnome-834ed838280978e68a7d0e449c58336901c1a149.tar.gz
freebsd-ports-gnome-834ed838280978e68a7d0e449c58336901c1a149.tar.zst
freebsd-ports-gnome-834ed838280978e68a7d0e449c58336901c1a149.zip
Use GTK and SDL.
We now have all the niceties of subtitles and menus and that sort of stuff. Mirror the archive on ftp.awfulhak.org and people.freebsd.org Bump PORTREVISION All ideas submitted by: Scott Lambert <lambert@lambertfam.org>
Diffstat (limited to 'multimedia/vlc-devel/Makefile')
-rw-r--r--multimedia/vlc-devel/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index c35481048995..9329f8318456 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -7,14 +7,28 @@
PORTNAME= vlc
PORTVERSION= 0.2.81
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/0.2.81/
+MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/0.2.81/ \
+ ftp://ftp.Awfulhak.org/pub/vlc/ \
+ http://people.FreeBSD.org/~brian/vlc/
MAINTAINER= brian@Awfulhak.org
-GNU_CONFIGURE= yes
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+USE_GTK= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
+pre-patch:
+ @${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/configure \
+ ${WRKSRC}/plugins/sdl/vout_sdl.c
+
.include <bsd.port.mk>